Edgewall Software
Modify

Opened 10 years ago

Closed 8 years ago

#1168 closed defect (worksforme)

WikiPages no more editable in IE (when using 0.8-stable r1211)

Reported by: groups@… Owned by: jonas
Priority: normal Milestone:
Component: general Version: 0.8
Severity: normal Keywords:
Cc: groups@…
Release Notes:
API Changes:

Description

  1. On any WikiPage click Edit This Page → Page gets opened in editable mode
  1. Do some modifications

3a. Click Preview

→ Page gets loaded as it has been before

3b. Click Save Changes

→ Page gets loaded as it has been before

It does work on your actual http://projects.edgewall.com/trac

Attachments (0)

Change History (4)

comment:1 Changed 9 years ago by malincog@…

I encountered this same problem. Firefox works fine. Using SSPI authentication on Windows. IE works if I just use anonymous but fails when I login as a domain user.

comment:2 Changed 9 years ago by malincog@…

  • Cc groups@… added
  • Resolution set to fixed
  • Status changed from new to closed

Figured this out. You need to add to your apache config file:

  • SSPIBasicPreferred On

in your <Location "/cgi-bin/trac.cgi/login"> (in the area with AuthType? SSPI etc.)

Got this information from http://svn.haxx.se/users/archive-2004-08/0847.shtml where and I quote:

Hi,

is there any viable workaround for apache+ssl+mod_auth_sspi+win32 that'll allow the same uri to be usable from both ie & subversion (tortoise specifically) ?

SSPIBasicPreferred On

Does nearly what you want, with this switch you can use IE with ssl/sspi (But not SVN or TSVN). I'm using a location with this setting for WebSVN, so I don't need native access with a browser. (Note that Firefox works fine, this is a IE problem!).

Jens

comment:3 Changed 8 years ago by mgood

  • Resolution fixed deleted
  • Status changed from closed to reopened

The fixed resolution is reserved for code changes, reopening to correct resolution.

Also, marking #2696 as a duplicate of this ticket.

comment:4 Changed 8 years ago by mgood

  • Resolution set to worksforme
  • Status changed from reopened to closed

This is a configuration issue with the necessary setting documented in TracOnWindows.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed The owner will remain jonas.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from jonas to the specified user.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.