Edgewall Software
Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#9833 closed defect (worksforme)

mod-pagespeed-beta-0.9.0.0-128 incompatible with Trac 0.12

Reported by: cyberscribe@… Owned by:
Priority: low Milestone:
Component: general Version: 0.12-stable
Severity: minor Keywords: mod_pagespeed, google
Cc:
Release Notes:
API Changes:

Description

Cross-posted on Google Code as well:

What steps will reproduce the problem?
1. Install Trac 0.12 using mod_python or mod_wsgi on Apache
2. Test performance
3. After several clicks, the site hangs

What is the expected output? What do you see instead?

Normal page loading speeds. Commenting out the line:

LoadModule pagespeed_module /usr/lib/httpd/modules/mod_pagespeed.so

causes Trac to behave normally again.

What version of the product are you using (please check X-Mod-Pagespeed
header)?

mod-pagespeed-beta-0.9.0.0-128

On what operating system?

CentOS release 5.5 (Final)
Linux dev 2.6.18-194.26.1.el5PAE #1 SMP Tue Nov 9 13:34:42 EST 2010 i686 i686 i386 GNU/Linux

Which version of Apache?

Server version: Apache/2.2.3
Server built:   Aug 30 2010 12:32:08
Server's Module Magic Number: 20051115:3
Server loaded:  APR 1.2.7, APR-Util 1.2.7
Compiled using: APR 1.2.7, APR-Util 1.2.7
Architecture:   32-bit

Which MPM?

Server MPM:     Prefork
  threaded:     no
    forked:     yes (variable process count)

Please provide any additional information below, especially a URL or an
HTML file that exhibits the problem.

From /var/log/httpd/error_log:

[Mon Nov 15 14:54:46 2010] [notice] [1115/145446:INFO:net/instaweb/apache/mod_instaweb.cc(247)] ModPagespeed OutputFilter called for request /changeset/4610[Mon Nov 15 14:54:46 2010] [notice] [1115/145446:INFO:net/instaweb/apache/mod_instaweb.cc(272)] unparsed=/changeset/4610, absolute_url=http://trac.davidco.com/changeset/4610
[Mon Nov 15 14:54:46 2010] [notice] [1115/145446:INFO:net/instaweb/util/google_message_handler.cc(48)] http://trac.davidco.com/changeset/4610:1: HtmlParse::StartParse
[Mon Nov 15 14:54:46 2010] [notice] [1115/145446:INFO:net/instaweb/apache/mod_instaweb.cc(299)] Request headers:\nHTTP/1.1 0 Internal Server Error\r\nHost: trac.davidco.com
\r\nUser-Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12\r\nAccept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8\r\nAccept-Language: en-us,en;q=0.5\r\nAccept-Encoding: gzip,deflate\r\nAccept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7\r\nKeep-Alive: 600\r\nConnection: kee
p-alive\r\nReferer: https://trac.davidco.com/ticket/475\r\nCookie: __utma=53671997.1988284187.1289234586.1289578563.1289581636.11; __utmz=53671997.1289234586.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none); trac_form_token=c66ebbe9b1629d50d94c186e; trac_session=699403b69a5529a41cf0eafa\r\nAuthorization: Basic cnBlYWtlOnc4NC5zZzM=\r\n\r\n
[Mon Nov 15 14:54:46 2010] [notice] [1115/145446:INFO:net/instaweb/apache/mod_instaweb.cc(302)] request->filename=/var/www/trac/html.wsgi, uri=/changeset/4610[Mon Nov 15 14:54:46 2010] [notice] [1115/145446:INFO:net/instaweb/apache/mod_instaweb.cc(319)] ModPagespeed Response headers:\nHTTP/1.1 200 OK\r\nETag: W/"anonymous/Tue, 12 Oct 2010 16:05:39 GMT/b5e995c78e43112146ef790a25a9958a"\r\nCache-Control: must-revalidate\r\nX-Mod-Pagespeed: 0.9.0.0-128\r\n\r\n
[Mon Nov 15 14:54:46 2010] [notice] [1115/145446:INFO:net/instaweb/util/google_message_handler.cc(48)] http://trac.davidco.com/changeset/4610:1: 1701us: HtmlParse::Flush
[Mon Nov 15 14:54:46 2010] [notice] [1115/145446:INFO:net/instaweb/util/google_message_handler.cc(48)] http://trac.davidco.com/changeset/4610:1: 1736us: HtmlParse::CoalesceAdjacentCharactersNodes
[Mon Nov 15 14:54:46 2010] [notice] [1115/145446:INFO:net/instaweb/util/google_message_handler.cc(48)] http://trac.davidco.com/changeset/4610:1: 1775us: HtmlParse::ApplyFilter:AddHead
[Mon Nov 15 14:54:46 2010] [notice] [1115/145446:INFO:net/instaweb/util/google_message_handler.cc(48)] http://trac.davidco.com/changeset/4610:126: 1818us: HtmlParse::SanityCheck
[Mon Nov 15 14:54:46 2010] [notice] [1115/145446:INFO:net/instaweb/util/google_message_handler.cc(48)] http://trac.davidco.com/changeset/4610:126: 1889us: HtmlParse::ApplyFilter:CssCombine
[Mon Nov 15 14:54:46 2010] [notice] [1115/145446:INFO:net/instaweb/apache/serf_url_async_fetcher.cc(632)] Initiating async fetch for http://trac.davidco.com/chrome/common/css/trac.css

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by anonymous

  • Resolution set to fixed
  • Status changed from new to closed

mod-pagespeed-beta-0.9.1.1-171 seems to be compatible, as Trac is no longer hanging up with it activated.

comment:2 Changed 4 years ago by rblank

  • Milestone 0.12.2 deleted
  • Resolution changed from fixed to worksforme

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.