Edgewall Software
Modify

Opened 5 years ago

Closed 3 years ago

#9590 closed defect (worksforme)

Display of Patch/Diff file broken

Reported by: hakre Owned by:
Priority: normal Milestone:
Component: rendering Version: 0.11.7
Severity: major Keywords: diff verify
Cc:
Release Notes:
API Changes:

Description

When looking into an attachment that is a patch file that contains changes to PHP code that is related to Diff, it looks like trac has problems to properly display that patchfile. It just stops somewhere in between.

Example: http://core.trac.wordpress.org/attachment/ticket/14726/14726.2.patch

Attachments (2)

14726.zip (2.6 KB) - added by hakre 5 years ago.
example file that originally broke - patch on example page has been replaced
14726.patch (12.3 KB) - added by Remy Blank 5 years ago.
Unpacked patch.

Download all attachments as: .zip

Change History (7)

Changed 5 years ago by hakre

Attachment: 14726.zip added

example file that originally broke - patch on example page has been replaced

comment:1 Changed 5 years ago by hakre

I needed to replace the original patch file of the example so making the example link not work any longer. To check, I've attached that original patch file here. I needed to put it in a zip otherwise it was reported as spam.

Changed 5 years ago by Remy Blank

Attachment: 14726.patch added

Unpacked patch.

comment:2 Changed 5 years ago by Remy Blank

Strangely, the patch from the .zip seems to be displayed correctly…

comment:3 Changed 5 years ago by Christian Boos

Component: generalrendering
Keywords: verify added

IIUC, the problem is with wp-includes/class-snoopy.php, which displays fine here, but not on core.trac.wordpress.org.

Maybe due to the default_encoding setting?

comment:4 Changed 5 years ago by Christian Boos

Keywords: diff added
Milestone: next-minor-0.12.x
Severity: normalmajor

comment:5 Changed 3 years ago by Christian Boos

Milestone: next-minor-0.12.x
Resolution: worksforme
Status: newclosed

Looks like the reported problematic link look fine now. They're now running 0.12.4, so I assume this must have been fixed along the way.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.