Edgewall Software
Modify

Opened 4 years ago

Closed 4 years ago

#9583 closed enhancement (fixed)

SpamFilter option to not filter attachments

Reported by: Ryan J Ollos <ryano@…> Owned by: dstoecker
Priority: normal Milestone:
Component: plugin/spamfilter Version:
Severity: normal Keywords:
Cc:
Release Notes:
API Changes:

Description

As discussed in a ticket on trac-hacks it would be nice to have the option to skip the scan of attachments.

I'd like to implement this feature for the 0.10 branch as well so that it can be used immediately on trac-hacks, which is running Trac 0.10.6dev.

Attachments (0)

Change History (4)

comment:1 Changed 4 years ago by dstoecker

Although there may be use cases for this, I would rather think Trac-Hacks should update to a more recent Trac and Spamfilter plugin and set better defaults (i.e. use Akismet and HTTP:BL and improved scores, points for registered users and so on). Ignoring attachments may be a fatal decision, as I often get HTML attachments uploaded, which contain spam.

Thought if you implement it, I will add it when reliable implemented.

comment:2 Changed 4 years ago by mrenzmann@…

Upgrading to Trac 0.12 is on the to-do-list already. We give a positive score of 9 for registered users, but in the mentioned cases they are "eaten" by negative points caused by the number of external URLs in the attachments. From what I can tell at this time, t-h.o currently sees only few spam attachments - most spam gets sent as comments to tickets or malicious edits of wiki pages.

comment:3 Changed 4 years ago by dstoecker

Implementation suggestion: Providing a score selection for attachments. For Track-Hacks this can then be set e.g. to 1000. Default should be 0.

comment:4 Changed 4 years ago by dstoecker

  • Resolution set to fixed
  • Status changed from new to closed

In r10075.

You need to backport it to 0.10 Trac yourself.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain dstoecker.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from dstoecker to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.