Edgewall Software
Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#9334 closed defect (cantfix)

AttributeError: 'NoneType' object has no attribute 'name'

Reported by: elisson Owned by:
Priority: highest Milestone:
Component: general Version: 0.11.7
Severity: critical Keywords:
Cc: support@…
Release Notes:
API Changes:

Description

How to Reproduce

While doing a GET operation on /oldbacklog/Sprint Backlog/Sprint #5, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'scope': u'Sprint #5', 'name': u'Sprint Backlog'}

User Agent was: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US) AppleWebKit/532.5 (KHTML, like Gecko) Chrome/4.1.249.1064 Safari/532.5

System Information

Trac 0.11.7
Python 2.4.3 (#1, Jun 11 2009, 14:09:37)
[GCC 4.1.2 20080704 (Red Hat 4.1.2-44)]
setuptools 0.6c5
SQLite 3.3.6
pysqlite 1.1.7
Genshi 0.5.1
mod_python 3.2.8
Agilo 0.8.4.1-r2322-20100129
Subversion 1.4.2 (r22196)
jQuery: 1.3.2

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/Trac-0.11.7-py2.4.egg/trac/web/main.py", line 450, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/Trac-0.11.7-py2.4.egg/trac/web/main.py", line 206, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.4/site-packages/agilo-0.8.4.1_r2322_20100129-py2.4.egg/agilo/api/view.py", line 155, in process_request
    return self._call_filters_and_handler(req, handler)
  File "/usr/lib/python2.4/site-packages/agilo-0.8.4.1_r2322_20100129-py2.4.egg/agilo/api/view.py", line 143, in _call_filters_and_handler
    data = handler(req) or {}
  File "/usr/lib/python2.4/site-packages/agilo-0.8.4.1_r2322_20100129-py2.4.egg/agilo/scrum/backlog/web_ui.py", line 812, in do_get
    self._do_show(req, data, backlog)
  File "/usr/lib/python2.4/site-packages/agilo-0.8.4.1_r2322_20100129-py2.4.egg/agilo/scrum/backlog/web_ui.py", line 474, in _do_show
    chart_widgets = self._load_chart_widgets(req, backlog)
  File "/usr/lib/python2.4/site-packages/agilo-0.8.4.1_r2322_20100129-py2.4.egg/agilo/scrum/backlog/web_ui.py", line 387, in _load_chart_widgets
    filter_by=filter_by)
  File "/usr/lib/python2.4/site-packages/agilo-0.8.4.1_r2322_20100129-py2.4.egg/agilo/charts/chart_generator.py", line 135, in get_chartwidget
    new_widget  = self._get_widget(name, kwargs, use_cache)
  File "/usr/lib/python2.4/site-packages/agilo-0.8.4.1_r2322_20100129-py2.4.egg/agilo/charts/chart_generator.py", line 110, in _get_widget
    new_widget = generator.generate_widget(name, **kwargs)
  File "/usr/lib/python2.4/site-packages/agilo-0.8.4.1_r2322_20100129-py2.4.egg/agilo/scrum/sprint/charts/resource_assignment_piechart.py", line 42, in generate_widget
    resource_widget.populate_with_sprint_data(sprint_name)
  File "/usr/lib/python2.4/site-packages/agilo-0.8.4.1_r2322_20100129-py2.4.egg/agilo/scrum/sprint/charts/resource_assignment_piechart.py", line 70, in populate_with_sprint_data
    self.data['resource_stats'] = SprintController(self.env).process_command(cmd_resources)
  File "/usr/lib/python2.4/site-packages/agilo-0.8.4.1_r2322_20100129-py2.4.egg/agilo/api/controller.py", line 333, in process_command
    return command.execute(self, date_converter, as_key)
  File "/usr/lib/python2.4/site-packages/agilo-0.8.4.1_r2322_20100129-py2.4.egg/agilo/api/controller.py", line 286, in execute
    return self._execute(controller, date_converter, as_key)
  File "/usr/lib/python2.4/site-packages/agilo-0.8.4.1_r2322_20100129-py2.4.egg/agilo/scrum/sprint/controller.py", line 926, in _execute
    sp_controller)
  File "/usr/lib/python2.4/site-packages/agilo-0.8.4.1_r2322_20100129-py2.4.egg/agilo/scrum/sprint/controller.py", line 881, in get_load_series_for_interval
    self._add_capacity_information(env, sprint.team.name,
AttributeError: 'NoneType' object has no attribute 'name'

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by rblank

  • Cc support@… added
  • Milestone 0.12 deleted
  • Resolution set to cantfix
  • Status changed from new to closed

comment:2 Changed 5 years ago by Martin Häcker <martin.haecker@…>

@reporter: I'm not sure what is happening here, it may be due to the sprint name containing a '#' (though I thought we already fixed that escaping bug one or two releases ago). If that is not the reason, please don't hesitate to join our support google group (for details see AgiloForScrum) so we can fix this problem.

@rblank: thanks for wrangling this issue! :-)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.