Edgewall Software
Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#8086 closed defect (fixed)

Custom Reports Fail with: ValueError: invalid literal for int() with base 10: ''

Reported by: bobbysmith007@… Owned by: cboos
Priority: normal Milestone: 0.11.4
Component: report system Version: 0.11.3
Severity: critical Keywords: custom reports
Cc:
Release Notes:
API Changes:

Description

I am the maintainer of the http://trac-hacks.org/wiki/TimingAndEstimationPlugin and in a recent version of Trac 12 (and 11.3) some of the custom reports stopped working.

The bug report on trac hacks points at r7906, though I think that just might be the version they is running rather than the version that caused the problem. There is also a log file attached to the trac hacks ticket. Please see: http://trac-hacks.org/ticket/4670 .

These reports have been being used consistently for may revisions of trac, so unless some assumptions have changed, these reports should be considered well tested against the sqlite backend.

I believe this might be caused by the total rows on the report which have an empty date.

Sorry if I have missed anything.

Attachments (1)

t8086-check-empty-string-date-report.patch (1.7 KB) - added by cboos 6 years ago.
Tentative fix for the issue - applies on latest 0.11-stable and probably also on trunk

Download all attachments as: .zip

Change History (6)

comment:1 in reply to: ↑ description Changed 6 years ago by cboos

  • Milestone set to 0.11.4
  • Owner set to cboos
  • Status changed from new to assigned

Replying to bobbysmith007@…:

… The bug report on trac hacks points at r7906, though I think that just might be the version they is running rather than the version that caused the problem.

Right, the "culprit" change seems rather to be r7766. I think we should just change the check for 'None' into a check for .

Changed 6 years ago by cboos

Tentative fix for the issue - applies on latest 0.11-stable and probably also on trunk

comment:2 Changed 6 years ago by cboos

Would you mind testing the patch above?

comment:3 Changed 6 years ago by cboos

  • Resolution set to fixed
  • Status changed from assigned to closed

Patch applied in r7919.

comment:4 Changed 6 years ago by anonymous

Shouldn't this patch be also applied to 0.12dev?

comment:5 Changed 6 years ago by cboos

Sure, I usually merge changes in batches, when I'm done ;-)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain cboos.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from cboos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.