Edgewall Software
Modify

Opened 8 years ago

Closed 8 years ago

#5061 closed defect (duplicate)

traceback when trying to attach image file to ticket

Reported by: Gary Wilson <gary.wilson@…> Owned by: jonas
Priority: normal Milestone:
Component: ticket system Version:
Severity: normal Keywords:
Cc: gary.wilson@…
Release Notes:
API Changes:

Description

Traceback (most recent call last):
  File "/home/trac/new-djangoproject-trac-test/trac/web/main.py", line 387, in dispatch_request
  File "/home/trac/new-djangoproject-trac-test/trac/web/main.py", line 237, in dispatch
  File "/home/trac/new-djangoproject-trac-test/trac/attachment.py", line 361, in process_request
  File "/home/trac/new-djangoproject-trac-test/trac/attachment.py", line 475, in _do_save
  File "build/bdist.linux-i686/egg/tracspamfilter/adapters.py", line 130, in validate_attachment
  File "build/bdist.linux-i686/egg/tracspamfilter/api.py", line 131, in test
  File "build/bdist.linux-i686/egg/tracspamfilter/model.py", line 119, in insert
  File "/home/trac/new-djangoproject-trac-test/trac/db/util.py", line 50, in execute
  File "/home/trac/new-djangoproject-trac-test/trac/db/util.py", line 50, in execute
  File "/usr/lib/python2.3/site-packages/pyPgSQL/PgSQL.py", line 3083, in execute
    parms = _quoteall(self.__unicodeConvert(parms[0]))
  File "/usr/lib/python2.3/site-packages/pyPgSQL/PgSQL.py", line 2300, in _quoteall
    t = tuple(map(_quote, vdict))
  File "/usr/lib/python2.3/site-packages/pyPgSQL/PgSQL.py", line 2268, in _quote
    return PgQuoteString(value)
TypeError: PgQuoteString() argument 1 must be string without null bytes, not str

The file: http://stereoit.com/django/favicon.ico

FYI, this was on Django's Trac instance, see http://code.djangoproject.com/ticket/3868

Attachments (1)

favicon.ico (1.4 KB) - added by Gary Wilson <gary.wilson@…> 8 years ago.

Download all attachments as: .zip

Change History (3)

Changed 8 years ago by Gary Wilson <gary.wilson@…>

comment:1 Changed 8 years ago by Gary Wilson <gary.wilson@…>

Works here though.

comment:2 Changed 8 years ago by eblot

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #4211, which is itself marked as a duplicate of #4087 (w/ a different error trace)

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed The owner will remain jonas.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from jonas to the specified user.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.