Edgewall Software
Modify

Opened 8 years ago

Closed 5 years ago

Last modified 5 years ago

#4564 closed defect (worksforme)

Toolbar icons not shown

Reported by: mtammerman@… Owned by: jonas
Priority: normal Milestone:
Component: general Version: 0.10.3
Severity: normal Keywords: needinfo
Cc: edgewall.p3u@…
Release Notes:
API Changes:

Description

I have just installed trac. Although all icons are seen, wikitoolbar formatting icons are not shown.

Attachments (0)

Change History (11)

comment:1 Changed 8 years ago by thatch

Are you saying there are boxes where the wiki toolbar buttons go, but no images?

comment:2 Changed 8 years ago by eblot

I'm not sure my problem is related to yours, but I've been unable the wikitoolbar to show up on my machine (Firefox 2.0) after I upgraded to 0.11dev. Are you actually running Trac 0.10.3 ?

Flushing the cache helped recovering the wikitoolbar, although I had to close and re-open Firefox to get it appear…

As a side note, Firefox complains about the following CSS statement source:/trunk/htdocs/css/trac.css@4612#L58

* html a.ext-link .icon { display: inline-block; }
Warning: Error in parsing value for property 'display'.  Declaration dropped.
Source File: http://server/tracdoc/css/trac.css
Line: 58

comment:3 Changed 8 years ago by cboos

Yes, {display: inline-block; } is apparently still not supported by Firefox 2.0, see http://www.quirksmode.org/css/display.html for example.

comment:4 Changed 8 years ago by thatch

Yes, plus * html is an IE CSS hack. Compliant browsers don't have an element that wraps html so don't care if there are unknown properties within it because they'll never take effect.

comment:5 Changed 8 years ago by cboos

  • Keywords needinfo added

Anyone was able to reproduce this problem lately?

comment:6 Changed 7 years ago by sid

  • Resolution set to worksforme
  • Status changed from new to closed

Closing due to lack of response (6 months) to query by cboos.

comment:7 Changed 5 years ago by edgewall.p3u@…

  • Cc edgewall.p3u@… added
  • Resolution worksforme deleted
  • Status changed from closed to reopened

Hi I can reproduce it on 11.6. The problem is that if one has TICKET_ADMIN rights (or TRAC_ADMIN) the /newticket site will not show the toolbar. For all (less privileged users) it will.

comment:8 Changed 5 years ago by rblank

  • Resolution set to worksforme
  • Status changed from reopened to closed

This seems to work for most Trac users, so I would guess this is an InstallationIssue or a PluginIssue. Please disable all your plugins, empty your browser cache, and try again. Then, re-add plugins one by one until the symptoms reappear. This should allow you to find the faulty plugin. You could then report the issue to the plugin maintainer.

In the unlikely event that you can reproduce the issue with a stock Trac installation (i.e. without any plugins), please open a new ticket and provide a precise description of the symptoms, together with steps to reproduce them.

comment:9 Changed 5 years ago by edgewall.p3u@…

OK I'll do that.

comment:10 Changed 5 years ago by dfleming@…

Just as an FYI I've been suffering through this for a while. I use quite a bit of plug-ins and I keep trac pretty much up to date with the latest and greatest stuff. Considering I use so many plugins it was a nightmare to figure out what was causing the problem since it really didn't start occurring until I did an upgrade to one version of Trac or another and It only affected certain sites as well as once the ticket was created all toolbars came back so yeah it was strange. Well to make a long story short. After reading an Above post I realized that one user was right in that it only happens to Trac admin privileges or Ticket Admin. So My problem ended up being (after going through plugins) a ticket delete plugin. I turned it off and everything else on and the problem went away. Hope this helps somebody.

comment:11 Changed 5 years ago by edgewall.p3u@…

Yes you are right. I can confirm that disabling the TicketDeletePlugin will activate the toolbar also for TRAC_ADMIN and TICKET_ADMIN. OK then off to the TicketDeletePlugin bug tracker…and reported: #trachacks7113)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain jonas.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from jonas to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.