Edgewall Software
Modify

Opened 8 years ago

Closed 5 years ago

#4235 closed defect (fixed)

Wiki formatting lost in ">" quoted blocks

Reported by: anonymous Owned by: cboos
Priority: high Milestone: 0.12
Component: wiki system Version: 0.10.2
Severity: normal Keywords: quote engine
Cc: dserodio@…, martin.marcher@…
Release Notes:
API Changes:

Description (last modified by cboos)

  1. Why not allow editing comments along with ticket itself?
  2. When replying to comment with quoting, wiki formatting will be lost in quoted text (e.g. numbering 1. 1. 1.)

Attachments (0)

Change History (18)

comment:1 follow-up: Changed 8 years ago by cboos

  • Description modified (diff)
  • Milestone set to 0.11
  1. See #454
  2. Yes, that would be a good thing.

… and:

  1. What do you think about having two reply buttons, one "Quote" doing what "Reply" does today, and "Reply" simply adding a reply to a specific comment, without quoting?

This would be especially interesting once we have #1835 (threaded view for comments).

comment:2 in reply to: ↑ 1 Changed 8 years ago by mgood

  • Component changed from general to wiki
  • Summary changed from Comments related to Wiki formatting lost in ">" quoted blocks

I'm updating the summary to reflect the core issue with the quote formatting. Right now it's possible to remove the ">" in front of some types of blocks and they'll be formatted, but still included in the quote.

For example:

> a
{{{
b
}}}
> c

is displayed as:

a

b

c

Replying to cboos:

  1. What do you think about having two reply buttons, one "Quote" doing what "Reply" does today, and "Reply" simply adding a reply to a specific comment, without quoting?

Coincidentally I just finished reading this Joel on Software article Choice = Headaches. Providing two buttons that do almost exactly the same thing adds unneeded clutter to the UI. It only takes a second to clear the textarea, so I'd rather keep just the one button.

comment:3 Changed 8 years ago by sid

#4095 was marked as duplicate of this ticket. It also noted that blank space is lost when replying to tickets.

For example, this:

> test
>
> test2

shows up as:

test

test2

comment:4 Changed 8 years ago by cboos

  • Keywords quote engine added

Right, the quoting related stuff in the Wiki engine really needs some improvements. I'm thinking of having "line prefix"-style rules that would be applied in turn, so that one could quote lists or other type of formatting (like tables).

comment:5 Changed 8 years ago by eblot

#4606 marked as a duplicate

comment:6 Changed 8 years ago by cboos

  • Priority changed from normal to high

#4615 also…

comment:7 Changed 8 years ago by cboos

  • Owner changed from jonas to cboos

comment:8 Changed 7 years ago by cboos

And another duplicate: #4965. I teally need to find some time to finish the WikiEngine refactoring :-)

comment:9 Changed 7 years ago by anonymous

  • Cc dserodio@… added

comment:10 Changed 7 years ago by cboos

  • Milestone changed from 0.11 to 0.12

WikiEngine refactoring postponed.

comment:11 Changed 7 years ago by anonymous

  • Cc martin.marcher@… added

comment:12 Changed 7 years ago by cboos

#6683, another duplicate, about the ability to quote code blocks.

comment:13 Changed 6 years ago by anonymous

  • Priority changed from high to normal

comment:14 Changed 6 years ago by anonymous

  • Priority changed from normal to high

comment:15 Changed 6 years ago by cboos

#7938 was closed as duplicate.

comment:16 Changed 5 years ago by Ryan Ollos <ryano@…>

I've seen similar behavior with quoting in the TracBacksPlugin that I now suspect is related to this issue: TH 5456, TH 5457.

comment:17 follow-up: Changed 5 years ago by cboos

Fixed in r9075.

However I just see that there's a glitch with comment:2

comment:18 in reply to: ↑ 17 Changed 5 years ago by cboos

  • Milestone changed from next-major-0.1X to 0.12
  • Resolution set to fixed
  • Status changed from new to closed

Replying to cboos:

Fixed in r9075.

However I just see that there's a glitch with comment:2

Fixed in r9076.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed The owner will remain cboos.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from cboos to the specified user.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.