Edgewall Software
Modify

Opened 9 years ago

Closed 8 years ago

#2577 closed defect (worksforme)

TracD (Windows): Trac URL not resolved after Login, Logout,, Settings Submit

Reported by: pusatine@… Owned by: jonas
Priority: normal Milestone:
Component: general Version: 0.9.2
Severity: normal Keywords:
Cc:
Release Notes:
API Changes:

Description (last modified by mgood)

This happens with version 0.9.2 and after upgrade to 0.9.3

There are several actions that I can take in Trac that result in a failed redirect and a page not found. Logging in (afer successful login), attempting to Logout, and several other actions (clicking on Submit button in the Settings page) have the same effect. To summarize, it looks like Trac is attempting a redirect back to the calling URL, but the URL output by Trac is mangled - prepended with http://None For example:

http://Nonehttp://10.28.34.167:8010/rxstream/settings

Here is the output from Firefox / Live HTTP headers:

http://10.28.34.167:8010/rxstream/settings

POST /rxstream/settings HTTP/1.1
Host: 10.28.34.167:8010
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Accept: text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
Accept-Language: en-us,en;q=0.5
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 300
Connection: keep-alive
Referer: http://10.28.34.167:8010/rxstream/settings
Cookie: trac_session=820e95aced91b9e2d8601f4e
Authorization: Digest username="xxxxxx", realm="xxxx", nonce="xxxxxxxxxxxxxxxxxxxxx", uri="/rxstream/settings", response="xxxxxxxxx", qop=auth, nc=00000004, cnonce="xxxxxxxx"
Content-Type: application/x-www-form-urlencoded
Content-Length: 56
action=save&name=&email=&newsid=820e95aced91b9e2d8601f4e
HTTP/1.x 302 Found
Server: tracd/0.9.2 Python/2.3.4
Date: Fri, 06 Jan 2006 20:25:18 GMT
Location: http://Nonehttp://10.28.34.167:8010/rxstream/settings
Content-Type: text/plain
Pragma: no-cache
Cache-Control: no-cache
Expires: Fri, 01 Jan 1999 00:00:00 GMT

Attachments (0)

Change History (6)

comment:1 Changed 9 years ago by mgood

  • Description modified (diff)

Fixed description

comment:2 Changed 9 years ago by anonymous

So, what about this problem?

comment:3 Changed 9 years ago by cboos

Have you tried to upgrade to milestone:0.9.4?

Read carefully ticket #2553, which might be related to your problem.

comment:4 Changed 9 years ago by anonymous

Thanks for the quick answer.

Yes, even tough I not using stunnel I've tried to apply the comments of ticket #2553 but the problems remains. I'm new to Trac, I just download it two days ago (file trac-0.9.4.win32.exe) and followed directions to install it on Windows running standalone (with tracd). Everything works very well, except for this problem. I did a quick search on google and I found some references for this problem, but no solution yet.

If you have some ideia, please let me now.

Thanks in advance!!

comment:5 Changed 9 years ago by anonymous

Anyone who knows to program in Python could pleasy try to do a simple workaround to solve this problem?

For instance, it must exists some function to remove a substring from a string. In this case just removing the "http://None" substring from the url should solve this problem. If someone knows, please give me directions of what file and/or functions should I change to try do something like that and how to compile the files to test.

Thanks.

comment:6 Changed 8 years ago by cboos

  • Resolution set to worksforme
  • Status changed from new to closed

Please reopen if the problem is still existing with 0.10.x

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain jonas.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from jonas to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.