Edgewall Software
Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#10309 closed defect (cantfix)

strange situation with several control elements when user have the TRAC_ADMIN or TICKET_ADMIN permissions

Reported by: slevin@… Owned by:
Priority: normal Milestone:
Component: ticket system Version: 0.12.2
Severity: normal Keywords: ticket TRAC_ADMIN TICKET_ADMIN needinfo
Cc:
Release Notes:
API Changes:

Description

When user have rights TRAC_ADMIN or TICKET_ADMIN - user can't use several controls elements when edit ticket or create a new ticket. In attachments two screenshots when user have granted TRAC_ADMIN permission (or TICKET_ADMIN) and without this rights.

Attachments (2)

make_ticket_with_trac_admin1.jpeg (54.0 KB) - added by slevin@… 3 years ago.
User have TRAC_ADMIN permission and can't use several control elements.
make_ticket_wo_trac_admin.jpeg (40.8 KB) - added by slevin@… 3 years ago.
The same user havn't TRAC_ADMIN permission and allways work fine

Download all attachments as: .zip

Change History (7)

Changed 3 years ago by slevin@…

User have TRAC_ADMIN permission and can't use several control elements.

Changed 3 years ago by slevin@…

The same user havn't TRAC_ADMIN permission and allways work fine

comment:1 Changed 3 years ago by rblank

  • Keywords needinfo added

The calendar icon comes from the th:DateFieldPlugin, not from Trac core.

I wouldn't be surprised if the other issue comes from the th:TracWysiwygPlugin, whose controls also seem to disappear. Can you please try again with the plugin disabled?

comment:2 Changed 3 years ago by slevin@…

So, U right, with plugin disabled - no any icons with any access rights, and as I understand you - my way - report to plugins autors - right?

comment:3 Changed 3 years ago by cboos

  • Resolution set to worksforme
  • Status changed from new to closed

Right!

So this is a PluginIssue.

comment:4 Changed 3 years ago by cboos

  • Resolution changed from worksforme to cantfix

comment:5 Changed 3 years ago by jomae

The issue is th:TicketDeletePlugin issue…. (th:#9081)

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.