Edgewall Software

Changes between Version 20 and Version 21 of setuptools


Ignore:
Timestamp:
Apr 9, 2017, 6:50:22 AM (2 years ago)
Author:
Ryan J Ollos
Comment:

Fix incorrect indentation of bullet point added in previous edit.

Legend:

Unmodified
Added
Removed
Modified
  • setuptools

    v20 v21  
    2323
    2424Notes:
    25  - Do not use setuptools prior to version **0.6c10**. If you are, look for the notes in an [./@9 earlier version] of this page.
    26  - If you're using Python 2.4 (still supported for 0.12-stable) or Python 2.5, you won't be able to use a recent version of setuptools. You can still install an earlier version:
    27     - grab and execute the older [http://peak.telecommunity.com/dist/ez_setup.py ez_setup.py] script, you'll then have 0.6c11, which is enough if you're installing from a Trac checkout made with Subversion 1.6, but is problematic for newer Subversion versions.
    28     - with easy_install from 0.6c11, install the latest Python 2.4/2.5 compatible version of the new setuptools: `easy_install -U setuptools==1.4.2`
    29     - Windows users will need to add the `Scripts` directory of their Python installation (for example, `C:\Python27\Scripts`) to their `PATH` environment variable, or use the full path to `easy_install` (for example, `C:\Python27\Scripts\easy_install.py`). See [http://peak.telecommunity.com/DevCenter/EasyInstall#windows-notes Windows notes] for more information.
    30 
    31  - if you're using setuptools versions **5.4** through **5.6**, the environment variable `PKG_RESOURCES_CACHE_ZIP_MANIFESTS` should be set, otherwise the performance of Trac will be significantly degraded.
     25- Do not use setuptools prior to version **0.6c10**. If you are, look for the notes in an [./@9 earlier version] of this page.
     26- If you're using Python 2.4 (still supported for 0.12-stable) or Python 2.5, you won't be able to use a recent version of setuptools. You can still install an earlier version:
     27 - grab and execute the older [http://peak.telecommunity.com/dist/ez_setup.py ez_setup.py] script, you'll then have 0.6c11, which is enough if you're installing from a Trac checkout made with Subversion 1.6, but is problematic for newer Subversion versions.
     28 - with easy_install from 0.6c11, install the latest Python 2.4/2.5 compatible version of the new setuptools: `easy_install -U setuptools==1.4.2`
     29- Windows users will need to add the `Scripts` directory of their Python installation (for example, `C:\Python27\Scripts`) to their `PATH` environment variable, or use the full path to `easy_install` (for example, `C:\Python27\Scripts\easy_install.py`). See [http://peak.telecommunity.com/DevCenter/EasyInstall#windows-notes Windows notes] for more information.
     30- if you're using setuptools versions **5.4** through **5.6**, the environment variable `PKG_RESOURCES_CACHE_ZIP_MANIFESTS` should be set, otherwise the performance of Trac will be significantly degraded.
    3231  - Linux: `$ export PKG_RESOURCES_CACHE_ZIP_MANIFESTS=1`
    3332  - Windows: `> set PKG_RESOURCES_CACHE_ZIP_MANIFESTS=1`