Edgewall Software

Changes between Version 107 and Version 108 of TracOnDebian


Ignore:
Timestamp:
Jul 20, 2008, 6:19:41 AM (11 years ago)
Author:
anonymous
Comment:

woody and sarge are outdated, etch and lenny are the current Debian releases

Legend:

Unmodified
Added
Removed
Modified
  • TracOnDebian

    v107 v108  
    1010'''Note:''' ''This page does not provide step-by-step instructions for installing and configuring all of Trac.  Use this page as a reference for installing the Debian software packages and the locations of configuration files, but you will need to read TracInstall and the other documentation sections for complete instructions on running and configuring Trac.''
    1111
    12 These instructions require the Debian Sarge release or newer.  There are instructions below for [wiki:TracOnDebian#Woodyoldstable installing Trac on Woody].  Check http://packages.debian.org/trac to see the latest available Trac version for your Debian release.
     12These instructions require the Debian Sarge release or newer.
     13Check http://packages.debian.org/trac to see the latest available Trac version for your Debian release.
     14Debian etch (stable) contains trac 0.10.3,
     15Debian (lenny, to be released in 2008) will probably have 0.11.
     16Debian sarge (oldstable) had 0.8.1, but 0.10.3 is available as backport.
    1317
    1418These instructions use the commandline tool `apt-get` to install the packages which you will need to run as the `root` user.  If you prefer to use a graphical tool such as `synaptic` you can search for the package names mentioned to install them.
     
    7377For Trac versions 0.8.x mod_python is recommended.  Trac [milestone:0.9] also supports FastCGI.  CGI instructions are provided, but this is not recommended since mod_python or FastCGI will give significantly better performance.
    7478
     79=== mod_wsgi ===
     80
     81See [wiki:TracModWSGI] for further instructions.
     82
    7583=== mod_python ===
    7684
     
    111119== Suggested Packages ==
    112120
    113 TracSyntaxColoring requires `enscript` and WikiRestructuredText requires `python-docutils`:
     121TracSyntaxColoring requires `pygments` (for trac >= 0.11) or `enscript` (before) and WikiRestructuredText requires `python-docutils`:
    114122
    115123{{{
    116     apt-get install enscript python-docutils
     124    apt-get install enscript python-docutils python-pygments
    117125}}}
    118 
    119 == Woody (oldstable) ==
    120 
    121 TODO
    122126
    123127== Comments ==