Edgewall Software

Version 6 (modified by Christian Boos, 13 years ago) ( diff )

Link to TracModPython#Troubleshooting added

This page documents the 1.4 (latest stable) release. Documentation for other releases can be found here.

Trac and mod_wsgi

mod_wsgi is an Apache module for running WSGI-compatible Python applications directly on top of Apache:

The mod_wsgi adapter is an Apache module that provides a WSGI compliant interface for hosting Python based web applications within Apache. The adapter is written completely in C code against the Apache C runtime and for hosting WSGI applications within Apache provides significantly better performance than using existing WSGI adapters for mod_python or CGI.

It is already possible to run Trac on top of mod_wsgi. This can be done by writing the following application script, which is just a Python file, though usually saved with a .wsgi extension).

import os

os.environ['TRAC_ENV'] = '/usr/local/trac/mysite'
os.environ['PYTHON_EGG_CACHE'] = '/usr/local/trac/mysite/eggs'

import trac.web.main
application = trac.web.main.dispatch_request

The TRAC_ENV variable should naturally be the directory for your Trac environment (if you have several Trac environments in a directory, you can also use TRAC_ENV_PARENT_DIR instead), while the PYTHON_EGG_CACHE should be a directory where Python can temporarily extract Python eggs. For clarity, you should give this file a .wsgi extension. You should probably put the file in it's own directory, since you will open up it's directory to Apache.

After you've done this, add the following to your httpd.conf.

WSGIScriptAlias /trac /usr/local/trac/mysite/apache/mysite.wsgi

<Directory /usr/local/trac/mysite/apache>
    WSGIApplicationGroup %{GLOBAL}
    Order deny,allow
    Allow from all
</Directory>

Here, the script is in a subdirectory of the Trac environment. In order to let Apache run the script, access to the directory in which the script resides is opened up to all of Apache. Additionally, Trac is always run in the first Python interpreter created by mod_wsgi; this is necessary because the Subversion Python bindings, which are used by Trac, don't always work in other subinterpreters and may crash Apache as a result. After adding this configuration, restart Apache, and then it should work.

See also the mod_wsgi installation instructions for Trac.

For troubleshooting tips, see the mod_python troubleshooting section, as most Apache-related issues are quite similar.

Note: See TracWiki for help on using the wiki.