Edgewall Software

Changes between Version 25 and Version 26 of TracDev/ApiChanges/1.3


Ignore:
Timestamp:
May 26, 2017, 4:57:09 AM (5 years ago)
Author:
Jun Omae
Comment:

Revise for CentOS 7.3

Legend:

Unmodified
Added
Removed
Modified
  • TracDev/ApiChanges/1.3

    v25 v26  
    7272The supported dependencies were determined by aiming to be compatible with the versions provided by the package managers on the following distros.
    7373
    74 || **Package** || **Ubuntu 16.04** || Ubuntu 14.04 || **Debian 8.8** || Debian 7.8 || **CentOS 7.2.1511** || CentOS 6.6 || **openSUSE 42.1** ||
    75 || Python      || 2.7.12 || 2.7.5            || 2.7.9        || 2.7.3      || 2.7.5               || 2.6.6      || 2.7.9             ||
    76 || Python3     || 3.5.2 || 3.4.0            || 3.4.2        || 3.2.3      || n/a                 || n/a        || 3.4.1             ||
    77 || Babel       || 1.3 || 1.3              || 1.3          || 0.9.6      || 0.9.6               || 0.9.4      || 1.3               ||
    78 || Genshi      || 0.7 || 0.7              || 0.7          || 0.6        || n/a                 || n/a        || 0.7               ||
    79 || SQLite3     || 3.11.0 || 3.8.2            || 3.8.7        || 3.7.13     || 3.7.17              || 3.6.20     || 3.8.10.2          ||
    80 || PostgreSQL  || 9.5.3 || 9.3.6            || 9.4.12        || 9.1.15     || 9.2.15              || 8.4.20     || 9.4, 9.3.11, 9.4.6 ||
    81 || MySQL       || 5.7.13 || 5.5.41, 5.6.19   || 5.5.55       || 5.5.41     || n/a                 || 5.1.73     || 5.6.30            ||
    82 || MariaDB     || 10.0.25 || 5.5.41           || 10.0.30     || n/a        || 5.5.47              || n/a        || 10.0.22           ||
    83 || psycopg2    || 2.6.1  || 2.4.5            || 2.5.4        || 2.4.5      || 2.5.1               || 2.0.14     || 2.6               ||
    84 || MySQLdb     || 1.3.7 || 1.2.3            || 1.2.3        || 1.2.3      || 1.2.3               || 1.2.3      || 1.2.5             ||
    85 || PyMySQL    || 0.7.2 || || n/a || || || || ||
    86 || SetupTools  || 20.7 || 3.3.1            || 5.5.1        || 0.6.24     || 0.9.8               || 0.6.10     || 18.0.1            ||
    87 || Git         || 2.7.4 || 1.9.1            || 2.1.4        || 1.7.10     || 1.8.3.1             || 1.7.1      || 2.6.6             ||
    88 || Subversion  || 1.9.3 || 1.8.8            || 1.8.10       || 1.6.17     || 1.7.14              || 1.6.11     || 1.8.10            ||
    89 || !DocUtils   || 0.12 || 0.11             || 0.12         || 0.8.1      || 0.11                || 0.6        || 0.11              ||
    90 || Textile     || 2.2.2 || 2.1.5            || 2.1.5        || 2.1.5      || n/a                 || n/a        || n/a               ||
    91 || Pygments    || 2.1 || 1.6              || 2.0.1        || 1.5        || 1.4                 || 1.1.1      || 1.6               ||
    92 || Apache      || 2.4.18 || 2.4.7            || 2.4.10       || 2.2.22     || 2.4.6               || 2.2.15     || 2.4.16            ||
    93 || mod_wsgi    || 4.3.0 || 3.4              || 4.3.0        || 3.3        || 3.4                 || 3.2        || 4.4.8             ||
    94 || mod_python  || 3.3.1 || 3.3.1            || 3.3.1        || 3.3.1      || n/a                 || n/a        || 3.5.0             ||
    95 || Nginx       || 1.10.0 || 1.4.6            || 1.6.2        || 1.2.1      || n/a                 || n/a        || 1.8.1             ||
    96 || **Last Updated** || || || 2017-05-25 || || || || || ||
     74|| **Package** || **Ubuntu 16.04** || Ubuntu 14.04 || **Debian 8.8** || Debian 7.8 || **CentOS 7.3** || CentOS 6.6 || **openSUSE 42.1** ||
     75|| Python      || 2.7.12           || 2.7.5          || 2.7.9        || 2.7.3      || 2.7.5          || 2.6.6      || 2.7.9             ||
     76|| Python3     || 3.5.2            || 3.4.0          || 3.4.2        || 3.2.3      || n/a            || n/a        || 3.4.1             ||
     77|| Babel       || 1.3              || 1.3            || 1.3          || 0.9.6      || 0.9.6          || 0.9.4      || 1.3               ||
     78|| Genshi      || 0.7              || 0.7            || 0.7          || 0.6        || n/a            || n/a        || 0.7               ||
     79|| SQLite3     || 3.11.0           || 3.8.2          || 3.8.7        || 3.7.13     || 3.7.17         || 3.6.20     || 3.8.10.2          ||
     80|| PostgreSQL  || 9.5.3            || 9.3.6          || 9.4.12       || 9.1.15     || 9.2.18         || 8.4.20     || 9.4, 9.3.11, 9.4.6 ||
     81|| MySQL       || 5.7.13           || 5.5.41, 5.6.19 || 5.5.55       || 5.5.41     || n/a            || 5.1.73     || 5.6.30            ||
     82|| MariaDB     || 10.0.25          || 5.5.41         || 10.0.30      || n/a        || 5.5.52         || n/a        || 10.0.22           ||
     83|| psycopg2    || 2.6.1            || 2.4.5          || 2.5.4        || 2.4.5      || 2.5.1          || 2.0.14     || 2.6               ||
     84|| MySQLdb     || 1.3.7            || 1.2.3          || 1.2.3        || 1.2.3      || 1.2.5          || 1.2.3      || 1.2.5             ||
     85|| PyMySQL     || 0.7.2            ||                || n/a          ||            || n/a            || n/a        ||                  ||
     86|| SetupTools  || 20.7             || 3.3.1          || 5.5.1        || 0.6.24     || 0.9.8          || 0.6.10     || 18.0.1            ||
     87|| Git         || 2.7.4            || 1.9.1          || 2.1.4        || 1.7.10     || 1.8.3.1        || 1.7.1      || 2.6.6             ||
     88|| Subversion  || 1.9.3            || 1.8.8          || 1.8.10       || 1.6.17     || 1.7.14         || 1.6.11     || 1.8.10            ||
     89|| !DocUtils   || 0.12             || 0.11           || 0.12         || 0.8.1      || 0.11           || 0.6        || 0.11              ||
     90|| Textile     || 2.2.2            || 2.1.5          || 2.1.5        || 2.1.5      || n/a            || n/a        || n/a               ||
     91|| Pygments    || 2.1              || 1.6            || 2.0.1        || 1.5        || 1.4            || 1.1.1      || 1.6               ||
     92|| Apache      || 2.4.18           || 2.4.7          || 2.4.10       || 2.2.22     || 2.4.6          || 2.2.15     || 2.4.16            ||
     93|| mod_wsgi    || 4.3.0            || 3.4            || 4.3.0        || 3.3        || 3.4            || 3.2        || 4.4.8             ||
     94|| mod_python  || 3.3.1            || 3.3.1          || 3.3.1        || 3.3.1      || n/a            || n/a        || 3.5.0             ||
     95|| Nginx       || 1.10.0           || 1.4.6          || 1.6.2        || 1.2.1      || n/a            || n/a        || 1.8.1             ||
     96|| **Last Updated** ||             ||                || 2017-05-25   ||            || 2017-05-25     ||            ||                  ||
    9797
    9898=== Deprecated Modules and APIs Removed
    99  
     99
    100100 - API change for `IEnvironmentParticipant` methods //[[ApiChanges/1.1#dbparametersremovedfromfunctionandmethodsignaturesinTrac1.1.2|removal of `db` parameter]]//, is now effective, see for example r15304
    101101
     
    104104== Detailed List of Developer Visible Changes #list
    105105
    106 [[TicketQuery(milestone=1.3.1,status=closed,apichanges!=,col=summary,rows=apichanges,group=component,format=table)]] 
     106[[TicketQuery(milestone=1.3.1,status=closed,apichanges!=,col=summary,rows=apichanges,group=component,format=table)]]
    107107
    108108== Other Modifications made to the 1.2 API
     
    110110=== Uncategorized Changes
    111111
    112 == New in the 1.3.1 API 
     112== New in the 1.3.1 API
    113113
    114114Be sure to have a look at the new ApiDocs ([http://www.edgewall.org/docs/trac-trunk/html/ for latest trunk]).