Edgewall Software

Changes between Version 2 and Version 3 of TracDev/ApiChanges/1.1.5


Ignore:
Timestamp:
Apr 19, 2015, 6:54:48 AM (7 years ago)
Author:
Ryan J Ollos
Comment:

ConfigObj dependency removed in #11982.

Legend:

Unmodified
Added
Removed
Modified
  • TracDev/ApiChanges/1.1.5

    v2 v3  
    7777|| Git         || Optional || >= 1.5.6 ||
    7878|| Subversion  || Optional || >= 1.6 ||
    79 || !ConfigObj  || Optional || Unspecified. Let's consider enforcing a minimum version, such as >= 5.0. !ConfigObj 5.0 released on [pypi:configobj/5.0.0 2014-02-15]  ||
    8079|| !DocUtils   || Optional || >= 0.3.9 ||
    8180|| Textile    || Optional || >= 2.0 ||
    8281|| Pygments   || Optional || >= 0.6. Let's consider bumping the requirement to at least 1.0, released in [https://pypi.python.org/pypi/Pygments/1.0 2008]  ||
    8382... please add any dependencies I've overlooked.
     83
     84`ConfigObj` is no longer a required dependency for the `AuthzPolicy` permission policy (`tracopt.perm.authz_policy`).
    8485
    8586=== Deprecated Modules Removed