Edgewall Software

Version 2 (modified by Christian Boos, 14 years ago) ( diff )

Added information about pysqlite 2.0.x

PySqlite

PySqlite is a Python binding for the SQLite light-weight database engine, which is Trac's default DatabaseBackend.

Currently Trac works best with SQLite 3 and the compatible bindings are:

  • either the 1.x release branch of PySqlite (version 1.1.6 as of this writing)
  • or the newer 2.0.x release branch (version ≥ 2.0.5 preferred)
  • (the upcoming 2.1.x release branch has just been started and has not yet been tested with Trac)

Recent versions available from there.

Note: It should still be possible to use the old SQLite 2.8.x with the Pysqlite 1.0.1.

Note: See TracWiki for help on using the wiki.