Edgewall Software

Changes between Version 1 and Version 2 of PySqlite


Ignore:
Timestamp:
Nov 8, 2005, 2:50:38 PM (17 years ago)
Author:
Christian Boos
Comment:

Added information about pysqlite 2.0.x

Legend:

Unmodified
Added
Removed
Modified
  • PySqlite

    v1 v2  
    55which is Trac's default DatabaseBackend.
    66
    7 Currently Trac is using the 1.x release branch of PySqlite
    8 (version 1.1.6 as of this writing).
     7Currently Trac works best with SQLite 3 and the compatible bindings are:
     8 * either the 1.x release branch of PySqlite (version 1.1.6 as of this writing)
     9 * or the newer 2.0.x release branch (version >= 2.0.5 preferred)
     10 * ''(the upcoming 2.1.x release branch has just been started and has not yet
     11   been tested with Trac)''
     12
     13Recent versions available from
     14[http://initd.org/tracker/pysqlite/wiki#Downloads there].
     15
     16''Note: It should still be possible to use the old SQLite 2.8.x
     17with the Pysqlite [http://initd.org/pub/software/pysqlite/releases/1.0/1.0.1 1.0.1].''