Edgewall Software

Changes between Version 6 and Version 7 of 0.12/TracInstall


Ignore:
Timestamp:
Nov 12, 2008, 12:27:47 PM (14 years ago)
Author:
Christian Boos
Comment:

Sync with r7673.

Legend:

Unmodified
Added
Removed
Modified
  • 0.12/TracInstall

    v6 v7  
    3535=== For SQLite ===
    3636
    37  * [http://www.sqlite.org/ SQLite], version 3.3.4 and above preferred.
     37 * [http://www.sqlite.org/ SQLite], version 3.3.4 and above preferred (note: it is preinstalled in Python 2.5.2).
    3838 * If not using Python-2.5: [http://pysqlite.org/ PySQLite], version 1.x (for SQLite 2.x) or version 2.x (for SQLite 3.x), version 2.3.2 preferred. For details see [trac:PySqlite PySqlite]
    3939
     
    4545
    4646 * [http://www.postgresql.org/ PostgreSQL]
    47  * [http://initd.org/projects/psycopg2 psycopg2] or [http://pypgsql.sourceforge.net/ pyPgSQL]
     47 * [http://initd.org/projects/psycopg2 psycopg2]
     48 * See [trac:wiki:DatabaseBackend#Postgresql DatabaseBackend]
    4849
    4950'''Warning''': PostgreSQL 8.3 uses a strict type checking mechanism. To use Trac with the 8.3 Version of PostgreSQL, you will need [http://trac.edgewall.org/changeset/6512 trac-0.11] or later.
     
    7071==== Web Server ====
    7172 * A CGI-capable web server (see TracCgi), or
    72  * a [http://fastcgi.com/ FastCGI]-capable web server (see TracFastCgi), or
    73  * [http://httpd.apache.org/ Apache] with [http://code.google.com/p/modwsgi/ mod_wsgi] (see [wiki:TracModWSGI])
     73 * a [http://www.fastcgi.com/ FastCGI]-capable web server (see TracFastCgi), or
     74 * an [http://tomcat.apache.org/connectors-doc/ajp/ajpv13a.html AJP]-capable web server (see [trac:TracOnWindowsIisAjp TracOnWindowsIisAjp]), or
     75 * [http://httpd.apache.org/ Apache] with [http://code.google.com/p/modwsgi/ mod_wsgi] (see [wiki:TracModWSGI] or http://code.google.com/p/modwsgi/wiki/IntegrationWithTrac)
    7476    * This should work with Apache 1.3, 2.0 or 2.2 and promises to deliver more performance than using mod_python. A little less mature than mod_python.
    7577 * [http://httpd.apache.org/ Apache] with [http://modpython.org/ mod_python 3.1.3+] (see TracModPython)
     
    8789'''Attention''': The various available versions of these dependencies are not necessarily interchangable, so please pay attention to the version numbers above. If you are having trouble getting Trac to work please double-check all the dependencies before asking for help on the [trac:MailingList MailingList] or [trac:IrcChannel IrcChannel].
    8890
    89 Please refer to the documentation of these packages to find out how they are best installed. In addition, most of the [wiki:TracInstallPlatforms platform-specific instructions] also describe the installation of the dependencies. Keep in mind however that the information there ''probably concern older versions of Trac than the one you're installing''.
     91Please refer to the documentation of these packages to find out how they are best installed. In addition, most of the [trac:TracInstallPlatforms platform-specific instructions] also describe the installation of the dependencies. Keep in mind however that the information there ''probably concern older versions of Trac than the one you're installing'' (there are even some pages that are still talking about Trac 0.8!).
    9092
    9193== Installing Trac ==