Edgewall Software

Opened 15 years ago

Last modified 5 years ago

#717 closed enhancement

When downloading or viewing a file with svn:keywords property set the keywords are not expanded — at Version 9

Reported by: alexs@… Owned by: Jonas Borgström
Priority: normal Milestone: 1.0.2
Component: version control/browser Version: 0.7.1
Severity: normal Keywords: svn:keywords patch review
Cc: alexs@…, joern.zaefferer@…, khali@…, roos@…, jsiirola@…, langenbach@… Branch:
Release Notes:
API Changes:

Description (last modified by Christian Boos)

Not sure if this is a bug against trac or against the python bindings, but when a file has say svn:keywords Id set as a property and a user tries to download the head revision or view the head revision the keyword expansion doesn't happen.

It would be nice if the keyword expansion happened so that the user gets a file with a version number in it.

Change History (9)

comment:1 by Christopher Lenz, 15 years ago

Reset milestone

comment:2 by Christopher Lenz, 15 years ago

Milestone: 0.7.11.0

comment:3 by daniel, 15 years ago

Milestone: 1.0Someday

comment:4 by daniel, 15 years ago

Resolution: wontfix
Status: newclosed

Almost certainly a subversion/pysvn issue.

comment:5 by Christian Boos, 14 years ago

Milestone: 1.0
Resolution: wontfix
Status: closedreopened
Type: defectenhancement

It's not a Subversion issue: fs.file_contents retrieves the raw content of the file in the repository. It's up to the caller to transform it, if needed.

And then, why not doing the keyword expansion, as requested here?

comment:6 by anonymous, 14 years ago

#2263 has been marked as duplicate of this ticket.

comment:7 by Christopher Lenz, 14 years ago

Description: modified (diff)
Keywords: svn:keywords added; svn:keyword removed
Summary: when downloading of viewing a file with svn:keyword properties set the keyword is not expanded When downloading or viewing a file with svn:keywords property set the keywords are not expanded

comment:8 by Jörn Zaefferer, 13 years ago

Cc: joern.zaefferer@… added

I'd like to second this request.

jQuery provides lots of it's plugins via the Trac svn browser, and it would help a lot when the files downloaded via the browser had the keywords expanded.

An example: I'm linking to this file in my plugin release page: http://dev.jquery.com/browser/trunk/plugins/treeview/jquery.treeview.js?format=txt

Any user downloading that file doesn't get the expanded property, therefore he can't tell me which revision he has when reporting an issue.

I'm willing to explore this problem in trac's code, though some more hints for what to look would be a great help, as I'm not familar with trac nor with python.

Thanks!

comment:9 by Christian Boos, 13 years ago

Description: modified (diff)

Note to self: it could be implemented using a custom content renderer for a file node, which would take over the Plain Text link.

To Jörn: there is a workaround. If the Trac Zip downloads were enabled at dev.jquery.com (see TracIni#browser-section), you could tell people to use the Zip Archive link at the bottom of the http://dev.jquery.com/browser/trunk/plugins/treeview/ page, which produces a Zip file with an explicit name (today, in this case, it would be trunk_plugins_treeview-r1392.zip).

Note: See TracTickets for help on using tickets.