Edgewall Software
Modify

Opened 13 years ago

Closed 13 years ago

#4162 closed defect (fixed)

InterWiki links can't start with CamelCase

Reported by: Tim Hatch <trac@…> Owned by: Christian Boos
Priority: low Milestone: 0.10.3
Component: wiki system Version: 0.10
Severity: minor Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

There's a great example of this on the top of InterMapTxt page right now, it has MeatBall:InterMapTxt which is displayed as a nonexistent wikilink and a link to itself. If the prefix is changed to meatball:InterMapTxt or anything else that isn't CamelCase then it works fine.

If this is by design, perhaps this link should be changed at the top of InterMapTxt so it works, and a note added to the paragraph about how they're case-insensitive, but that you can't use CamelCase. Noticed on t.e.o. and on devel.

Attachments (0)

Change History (2)

comment:1 by Christian Boos, 13 years ago

Milestone: 0.10.3
Owner: changed from Jonas Borgström to Christian Boos

Oops, no, that used to work ;)

comment:2 by Christian Boos, 13 years ago

Resolution: fixed
Status: newclosed

Fixed in r4279 and r4280.

Thanks for spotting this!

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted.
to The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.