Edgewall Software
Modify

Opened 13 years ago

Closed 13 years ago

#3875 closed defect (wontfix)

Changesets that have only added new files throw SubversionException: ('No such revision'...

Reported by: james@… Owned by: Christian Boos
Priority: normal Milestone:
Component: version control/changeset view Version: 0.10
Severity: normal Keywords: svn
Cc: Branch:
Release Notes:
API Changes:

Description

Seems that with the Trac 0.10, any repository that has a changeset which only added new files (no modifications to existing files, only new files were added) throws the "No such revision" error with Trac.

Doing a "trac-admin resync" does not solve this issue, which is always the typical solution proposed for these issues.

Python Traceback

Traceback (most recent call last):
  File "/opt/csw/lib/python2.3/site-packages/trac/web/main.py", line 356, in dispatch_request
    dispatcher.dispatch(req)
  File "/opt/csw/lib/python2.3/site-packages/trac/web/main.py", line 224, in dispatch
    resp = chosen_handler.process_request(req)
  File "/opt/csw/lib/python2.3/site-packages/trac/versioncontrol/web_ui/changeset.py", line 255, in process_request
    diff_args, diff_options)
  File "/opt/csw/lib/python2.3/site-packages/trac/versioncontrol/web_ui/changeset.py", line 477, in _render_html
    for old_node, new_node, kind, change in get_changes():
  File "/opt/csw/lib/python2.3/site-packages/trac/versioncontrol/web_ui/changeset.py", line 303, in get_changes
    new_node = repos.get_node(npath, rev)
  File "/opt/csw/lib/python2.3/site-packages/trac/versioncontrol/cache.py", line 114, in get_node
    return self.repos.get_node(path, rev)
  File "/opt/csw/lib/python2.3/site-packages/trac/versioncontrol/svn_fs.py", line 354, in get_node
    self.pool)
  File "/opt/csw/lib/python2.3/site-packages/trac/versioncontrol/svn_fs.py", line 531, in __init__
    self.root = fs.revision_root(fs_ptr, rev, self.pool())
  File "/opt/csw/lib/python2.3/libsvn/fs.py", line 218, in svn_fs_revision_root
    return apply(_fs.svn_fs_revision_root, args)
SubversionException: ('No such revision 89', 160006)

Attachments (0)

Change History (9)

comment:1 by Christian Boos, 13 years ago

Did you also upgrade to svn 1.4 by any chance and forgot to update the bindings?

comment:2 by Christian Boos, 13 years ago

Keywords: needinfo added

comment:3 by Christian Boos, 13 years ago

Any news on this one? Does the revision 89 even exist? Is the problem always there or only intermittently? What is the Subversion version used, and the fs backend (fsfs or bdbfs?).

Please give as much details as you can, otherwise we can't act on the ticket.

comment:4 by Christian Boos, 13 years ago

Keywords: svn added

comment:5 by Christian Boos, 13 years ago

Keywords: needinfo removed
Resolution: wontfix
Status: newclosed

Closing the ticket, as my questions in comment:3 didn't get answered…

Please don't hesitate to reopen if the problem persists (+ give us the needed info).

in reply to:  3 comment:6 by bmichaelsen@…, 13 years ago

Resolution: wontfix
Status: closedreopened

Replying to cboos:

Any news on this one?

I have the same issue here and notice it esp. when branching/tagging ("svn cp"/"svn mkdir")

Does the revision 89 even exist?

In my case the revisions most certainly exist (they are browsable in webdav).

Is the problem always there or only intermittently?

The problem is there until apache gets restarted. I have one case where i commited two revisions (svn mkdir and svn cp) and clicking on the timeline showed some strange behavior: sometimes the internal error said rev 283 does not exist, sometimes it said rev 284 does not exist, although both certainly do.

What is the Subversion version used, and the fs backend (fsfs or bdbfs?).

trac-0.10.1
apache-2.0.58
mod_python-3.1.4
python-2.4.3
subversion-1.4.2 fsfs-Backend
gentoo

Please give as much details as you can, otherwise we can't act on the ticket.

Restarting apache solves the issue.

comment:7 by bmichaelsen@…, 13 years ago

Resolution: fixed
Status: reopenedclosed

seems to be fixed in 0.10.3. closing the bug.

comment:8 by Christian Boos, 13 years ago

Resolution: fixed
Status: closedreopened

Reopening, as I don't see what 0.10.x has changed w.r.t. to the original issue (I believe the error reported in comment:6 was rather a duplicate of #4132).

This ticket is more about Subversion itself raising an exception:

...
  File "/opt/csw/lib/python2.3/libsvn/fs.py", line 218, in svn_fs_revision_root
    return apply(_fs.svn_fs_revision_root, args)
SubversionException: ('No such revision 89', 160006)

Therefore I'll restore the original wontfix resolution.

comment:9 by Christian Boos, 13 years ago

Resolution: wontfix
Status: reopenedclosed

… unless someone can provide a way to understand or reproduce the original error.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.