Edgewall Software
Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#12736 closed enhancement (fixed)

Omit "Comment" in comment diff

Reported by: Ryan J Ollos Owned by: Ryan J Ollos
Priority: normal Milestone: 1.3.2
Component: ticket system Version:
Severity: normal Keywords:
Cc: Branch:
Release Notes:

Empty Comment field is not displayed when viewing diff of a comment.

API Changes:

Description

When viewing a comment diff, e.g. here, the Comment: entry in the dl#overview is always empty and will always be empty because there's no input to "comment on a comment edit". We could just conditionally not show the Comment: entry.

Attachments (0)

Change History (9)

comment:1 by Ryan J Ollos, 3 years ago

Milestone: next-stable-1.2.x1.3.2
Owner: set to Ryan J Ollos
Status: newassigned

comment:2 by Ryan J Ollos, 3 years ago

Proposed changes in [6c30aa6a/rjollos.git].

comment:3 by Ryan J Ollos, 3 years ago

Release Notes: modified (diff)
Resolution: fixed
Status: assignedclosed

Fixed in r15767.

comment:4 by Ryan J Ollos, 3 years ago

So far I'm not seeing the cause of this failure.

comment:5 by Ryan J Ollos, 3 years ago

Failure seems to be intermittent. I've seen it once locally. Added another URL assertion in r15776.

comment:6 by Ryan J Ollos, 3 years ago

Failure persists intermittently after r15776.

comment:7 by Ryan J Ollos, 3 years ago

Additional change in r15887.

comment:8 by Ryan J Ollos, 3 years ago

Additional change in r15930. The change avoids using random content for the comments. I don't see how that would affect the result, but I don't have any other ideas.

comment:9 by Ryan J Ollos, 3 years ago

Test failures fixed in #12822.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Ryan J Ollos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.