Edgewall Software

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#12391 closed enhancement (fixed)

No languages available when installing Trac as wheel — at Version 6

Reported by: Ryan J Ollos Owned by: Jun Omae
Priority: normal Milestone: 1.0.11
Component: i18n Version:
Severity: normal Keywords:
Cc: Branch:
Release Notes:

Trac is distributed as a pure Python Wheel package.

API Changes:
Internal Changes:

Description

When Trac is install as a wheel, the default when using pip, the languages aren't available.

$pip install trac
Collecting trac
Requirement already satisfied (use --upgrade to upgrade): Genshi>=0.6 in ./pve/lib/python2.7/site-packages (from trac)
Requirement already satisfied (use --upgrade to upgrade): setuptools>=0.6b1 in ./pve/lib/python2.7/site-packages (from trac)
Installing collected packages: trac
Successfully installed trac-1.0.10

However, if Trac is installed using the --no-binary option, languages are available.

$pip install --no-binary=trac trac
Collecting trac
  Using cached Trac-1.0.10.tar.gz
Requirement already satisfied (use --upgrade to upgrade): setuptools>=0.6b1 in ./pve/lib/python2.7/site-packages (from trac)
Requirement already satisfied (use --upgrade to upgrade): Genshi>=0.6 in ./pve/lib/python2.7/site-packages (from trac)
Skipping bdist_wheel for trac, due to binaries being disabled for it.
Installing collected packages: trac
  Running setup.py install for trac ... done
Successfully installed trac-1.0.10

Change History (6)

comment:1 by Jun Omae, 5 years ago

That is not a Trac issue. I think you've installed Trac without Babel and created *.whl package is reused.

$ /dev/shm/t12391/bin/pip install --verbose Trac
Collecting Trac
  1 location(s) to search for versions of Trac:
  * https://pypi.python.org/simple/trac/
  Getting page https://pypi.python.org/simple/trac/
...
  Using cached wheel link: file:///home/jun66j5/.cache/pip/wheels/65/c0/65/8d2adb686e28b3b930ff9a26f1d04ebe7a47266732ee45a680/Trac-1.0.10-cp27-none-any.whl
...
Last edited 5 years ago by Jun Omae (previous) (diff)

comment:2 by Jun Omae, 5 years ago

Reconsidering, we could upload *.whl package with language files to PyPI in order to install without local-building.

comment:3 by Ryan J Ollos, 5 years ago

Milestone: next-stable-1.0.x1.0.11
Type: defectenhancement

It looks like you are correct. Languages are available if installing wheel using --no-cache-dir option.

I like the idea of creating a wheel at the next release. I guess we should create a pure python wheel since we don't yet support Python 3.

comment:4 by Ryan J Ollos, 5 years ago

Release Notes: modified (diff)
Resolution: fixed
Status: newclosed

Updated release checklist in TracDev/ReleaseChecklist@104.

comment:5 by Ryan J Ollos, 5 years ago

Owner: set to Jun Omae

comment:6 by Ryan J Ollos, 5 years ago

Release Notes: modified (diff)
Note: See TracTickets for help on using tickets.