Edgewall Software
Modify

Opened 5 years ago

Closed 5 years ago

#11734 closed defect (worksforme)

OperationalError: unable to open database file

Reported by: admin Owned by:
Priority: low Milestone:
Component: general Version: 1.0.1
Severity: critical Keywords: needinfo
Cc: Branch:
Release Notes:
API Changes:

Description

How to Reproduce

While doing a POST operation on /admin/ticket/components/O2O_V3, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'20f95dac2ceebd06c34eb051',
 'cat_id': u'ticket',
 'description': u'O2O V3\u4ea7\u54c1\u7ebf\uff0c\u5305\u62ec:\u8861\u767e\u3001\u516d\u5b89',
 'name': u'O2O_V3',
 'owner': u'admin',
 'panel_id': u'components',
 'path_info': u'O2O_V3',
 'save': u'\u4fdd\u5b58'}

User agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/36.0.1985.143 Safari/537.36

System Information

Trac 1.0.1
Babel 0.9.6
Genshi 0.7 (without speedups)
pysqlite 2.6.0
Python 2.7.8 (default, Jun 30 2014, 16:03:49) [MSC v.1500 32 bit (Intel)]
pytz 2014.4
setuptools 5.7
SQLite 3.6.21
jQuery 1.7.2

Enabled Plugins

tracaccountmanager 0.4.4

Python Traceback

Traceback (most recent call last):
  File "c:\python27\lib\site-packages\trac\web\main.py", line 497, in _dispatch_request
    dispatcher.dispatch(req)
  File "c:\python27\lib\site-packages\trac\web\main.py", line 214, in dispatch
    resp = chosen_handler.process_request(req)
  File "c:\python27\lib\site-packages\trac\admin\web_ui.py", line 125, in process_request
    path_info)
  File "c:\python27\lib\site-packages\trac\ticket\admin.py", line 55, in render_admin_panel
    return self._render_admin_panel(req, cat, page, version)
  File "c:\python27\lib\site-packages\trac\ticket\admin.py", line 91, in _render_admin_panel
    comp.update()
  File "c:\python27\lib\site-packages\trac\ticket\model.py", line 885, in update
    self._old_name))
  File "c:\python27\lib\site-packages\trac\db\util.py", line 121, in execute
    cursor.execute(query, params)
  File "c:\python27\lib\site-packages\trac\db\util.py", line 65, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "c:\python27\lib\site-packages\trac\db\sqlite_backend.py", line 78, in execute
    result = PyFormatCursor.execute(self, *args)
  File "c:\python27\lib\site-packages\trac\db\sqlite_backend.py", line 56, in execute
    args or [])
  File "c:\python27\lib\site-packages\trac\db\sqlite_backend.py", line 48, in _rollback_on_error
    return function(self, *args, **kwargs)
OperationalError: unable to open database file

Attachments (0)

Change History (11)

comment:1 by Ryan J Ollos, 5 years ago

Probably a permission issue, but maybe your [trac] database string is incorrect.

comment:2 by Ryan J Ollos, 5 years ago

Resolution: cantfix
Status: newclosed

comment:3 by anonymous, 5 years ago

Resolution: cantfix
Status: closedreopened

but the error just only occur when browser POST to server url /admin/ticket/components/O2O_V3 ,such as modify a component or modify a milestone, and other operations like GET any url , Create a component, create a ticket or view anything , it is work fine.

comment:4 by Ryan J Ollos, 5 years ago

Please confirm that you have sufficient disk space and that your database file is not located on a network disk. Also, please check that the issue can be reproduced at different times of the day for this single component, and that the issue is not intermittent.

Last edited 5 years ago by Ryan J Ollos (previous) (diff)

in reply to:  4 comment:5 by anonymous, 5 years ago

Replying to rjollos:

Please confirm that you have sufficient disk space and that your database file is not located on a network disk. Also, please check that the issue can be reproduced at different times of the day for this single component, and that the issue is not intermittent.

the issue is not intermittent and can always be reproduced, in admin panel , any item under admin menu :" Ticket System", eg , components, milestones, priorites, resolutions… when modify any item and save it, then the error is raising.

Version 0, edited 5 years ago by anonymous (next)

in reply to:  4 ; comment:6 by anonymous, 5 years ago

Replying to rjollos:

Please confirm that you have sufficient disk space and that your database file is not located on a network disk. Also, please check that the issue can be reproduced at different times of the day for this single component, and that the issue is not intermittent.

and If you are willing to view the issue scene, you can open the url : http://www.comteck.cn:8000/comteck/admin

using accout: admin password: admin

edit one component or other item, you can reproduced the issue.

thanks a lot! the account will be valid in 3 days

in reply to:  6 ; comment:7 by Christian Boos, 5 years ago

Replying to anonymous:

and If you are willing to view the issue scene, you can open the url […]

Ok, so it really seems that there's something unusual happening on your system…

Any UPDATE request which has to do with the version, milestone, component or enum tables will trigger this error. INSERT and DELETE seem to work fine. Editing the description of a report also works fine (?).

There's a hint in the Django's NewbieMistakes page mentioning that this issue could happen on Windows due to Anti-virus software getting in the way, so you could try to disable it if you happen to use one…

Others mention trouble with paths used for the temporary files. Finally, this report and the related googleappengine issue 7717 describe pretty much the same symptoms as you have and suggests several workarounds you could try (setting TMP or TEMP environment variable, running as Administrator).

Note that I never faced this issue myself on Windows x64 with Python 2.7 and SQLite, despite this being my default development environment, but then I use an account with administrative privileges (and no antivirus software infect my system ;-) ).

in reply to:  7 ; comment:8 by anonymous, 5 years ago

Replying to cboos:

Replying to anonymous:

and If you are willing to view the issue scene, you can open the url […]

Ok, so it really seems that there's something unusual happening on your system…

thanks a lot, i realize it maybe caused by tracaccountmanager plugin, and the account named admin which created by tracaccountmanager may not have permission to edit the component.

in reply to:  8 comment:9 by Ryan J Ollos, 5 years ago

Replying to anonymous:

thanks a lot, i realize it maybe caused by tracaccountmanager plugin, and the account named admin which created by tracaccountmanager may not have permission to edit the component.

If the account didn't have permission to edit the component you wouldn't be able to access the edit page, so I don't see how this could be associated with any account or permission issues.

comment:10 by Christian Boos, 5 years ago

Keywords: needinfo added
Priority: normallow

Any news on this one?

comment:11 by Ryan J Ollos, 5 years ago

Resolution: worksforme
Status: reopenedclosed

Closing since there has been no feedback for > 5 months.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.