Edgewall Software
Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#11261 closed defect (duplicate)

Genshi UnicodeEncodeError error while rendering template (unknown template location)

Reported by: ktk@… Owned by:
Priority: normal Milestone:
Component: report system Version: 1.0.1
Severity: normal Keywords: genshi
Cc: Branch:
Release Notes:
API Changes:

Description (last modified by anonymous)

I run a TRAC with many hosted projects at http://svn.netlabs.org

For one particular project (http://svn.netlabs.org/java/ there is a report we cannot execute anymore, I get the Genshi UnicodeEncodeError: http://svn.netlabs.org/java/report/14

There report is "All active tickets with change date" :

SELECT p.value AS __color__,
   id AS ticket, summary, component, version, milestone, t.type AS type, 
   owner, status,
   time AS created,
   changetime AS modified, reporter AS reporter, description AS _description_
  FROM ticket t
  LEFT JOIN enum p ON p.name = t.priority AND p.type = 'priority'
  WHERE status <> 'closed' 
  ORDER BY modified desc

The query works fine directly on trac.db (sqlite). It also works on all the other projects we have so it seems not to be a general TRAC problem on our setup. I can reproduce the problem on a newly initialized environment, the report works first, then I replace trac.db with the trac.db of this particular project and from that point I get the error.

I suspect there is something in the SQL query which seems to confuse the rendering part. It's an open source project so I made the trac.db available: http://ktk.netlabs.org/misc/trac.db.gz (10MB gzipped).

There are no errors logged in the error-log from Apache.

Attachments (0)

Change History (8)

comment:1 by anonymous, 6 years ago

Description: modified (diff)

comment:2 by Jun Omae, 6 years ago

Thanks for providing trac.db. However, cannot reproduce it. Also, it caused by the description of #153. The pages, http://svn.netlabs.org/java/ticket/153 and http://svn.netlabs.org/java/query?id=153&col=id&order=priority&row=description, occur the same error.

I think that some plugins bring the errors. Please try to disable all plugins and check $TRACENV/log/trac.log in your Trac. Could you please provide "System Information" and "Installed Plugins" in "About Trac" page of the site?

Last edited 6 years ago by Jun Omae (previous) (diff)

comment:3 by ktk@…, 6 years ago

Hmm thanks didn't even notice yet that the other pages create that error as well. You can see the whole "About Trac" here, I just removed some passwords: http://ktk.netlabs.org/misc/about-trac.html

I know there are some plugins I installed but I fail to remember where I can find them (Piwik for example). I couldn't find any options in the admin tab.

I checked the trac.log, there is some stuff logged but not related to this error, when it happens on the page I don't see much. Should I increase the log level?

in reply to:  3 comment:4 by Jun Omae, 6 years ago

Replying to ktk@…:

Hmm thanks didn't even notice yet that the other pages create that error as well. You can see the whole "About Trac" here, I just removed some passwords: http://ktk.netlabs.org/misc/about-trac.html

Thanks for the information. Reproduced with Genshi 0.7! The workaround is to use Genshi 0.6.1/0.6.0.

I'll investigate it.

comment:5 by Jun Omae, 6 years ago

Keywords: genshi added
Milestone: 1.0.2
Release Notes: modified (diff)
Resolution: fixed
Status: newclosed

The issue is caused by wiki bracketed link <http://....> on Genshi 0.7. Also, it already has been fixed in [11683], 1.0-stable branch. The fix will be included in Trac 1.0.2 (not yet release).

Thanks.

comment:6 by Ryan J Ollos, 6 years ago

This should probably be marked as a duplicate of #11218. We might want to update #11218 with a more descriptive Release Note, like the one added to this ticket.

comment:7 by Jun Omae, 6 years ago

Milestone: 1.0.2
Release Notes: modified (diff)
Resolution: fixedduplicate

Sure. Close a duplicate of #11218.

comment:8 by ktk@…, 6 years ago

Great thanks guys. I found some other tickets but not this one, thanks for the fixes!

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.