Edgewall Software
Modify

Opened 5 years ago

Closed 5 years ago

#7736 closed defect (duplicate)

"Page not Found" when creating or updating a ticket

Reported by: danilov@… Owned by:
Priority: normal Milestone:
Component: web frontend Version: 0.11.3
Severity: major Keywords: python26
Cc: mark@…
Release Notes:
API Changes:

Description

When I create or update a ticket I am getting "Page not found" error, however when I go to active tickets I see that the ticket was actually created or updated. Operating system: RHEL4. Python version: 2.6. I am running Trac as standalone server using tracd.

Attachments (0)

Change History (9)

comment:1 Changed 5 years ago by rblank

  • Keywords needinfo added; page not found removed

Could you please set your log level to DEBUG and attach the log output when creating a new ticket and when updating a ticket? This might be an issue with Python 2.6.

comment:2 Changed 5 years ago by danilov@…

  • Resolution set to fixed
  • Status changed from new to closed

Your guess about Python 2.6 was right! I fixed the issue by rolling back to Python version 2.5.2 and reinstalling Trac. Thank you!

comment:3 Changed 5 years ago by eblot

  • Keywords python2.6 added; needinfo removed
  • Resolution fixed deleted
  • Status changed from closed to reopened

Re-opening: Trac should work fine with Python 2.6.

Maybe a dedicated ticket should be created.

comment:4 Changed 5 years ago by cboos

  • Keywords python26 added; python2.6 removed

Yes, I had the same thought. 2.6 works fine for me (tracd, Windows x64).

danilov, please attach your trac.log file showing the exact error you get (see TracLogging for details).

comment:5 Changed 5 years ago by thatch

The automated tests caught a few issues under 2.6. Here's a summary:

  • three functional tests fail to redirect after attachment creation (though reproducible under the test env, I can't make it happen by hand)
  • one is broken due to a deprecation warning on accessing an exception message
  • one fails because to_unicode(Exception) is evidently returning an empty string (related to the previous one?)

None of these seem to be the direct issue this ticket is addressing.

danilov, can you report what the url is for the /newticket page and what it is when you get "Page not found"?

comment:6 Changed 5 years ago by thatch

Also, what Genshi version were you using under 2.6?

comment:7 Changed 5 years ago by cboos

  • Resolution set to worksforme
  • Status changed from reopened to closed

Please reopen if there are still issues like this with Trac-0.11.3, which should fully support Python 2.6.

comment:8 Changed 5 years ago by viin

  • Resolution worksforme deleted
  • Status changed from closed to reopened
  • Version changed from 0.11.1 to 0.11.3

When I use "Internet Explorer" I get "Page not Found" when I post new tickets (or change properties in the admin-pages).

When I use Firefox or Opera it seems to work.

Using:

  • Python 2.5.4
  • Genshi 0.5.1
  • Tracd as standalone server.

comment:9 Changed 5 years ago by cboos

  • Resolution set to duplicate
  • Status changed from reopened to closed

See #8020.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.