Edgewall Software

Opened 12 years ago

Closed 8 years ago

#216 closed enhancement (fixed)

Paging Support: Report (ticket listing)

Reported by: rocky Owned by: Christian Boos
Priority: high Milestone: 0.11
Component: report system Version: devel
Severity: major Keywords: paginate query
Cc: coderanger@…, trac-ja@…
Release Notes:
API Changes:


Report (ticket listings) need to be have next/previous links and only show a certain number of items on the same screen.

Attachments (1)

report.patch (4.1 KB) - added by liris <liris.pp@…> 9 years ago.
paginate patch for report

Download all attachments as: .zip

Change History (17)

comment:1 Changed 12 years ago by Jonas Borgström

  • Milestone set to 0.8

comment:2 Changed 11 years ago by daniel

  • Milestone changed from 0.8 to 0.9

comment:3 Changed 10 years ago by Christopher Lenz

  • Milestone changed from 0.9 to 1.0

comment:4 Changed 9 years ago by cfunk@…

I would second this. we are a large company that has over 6K tickets in our current. I am interested in giving trac a whirl, but it needs to be able to page reporting queries. Even running reports on your own trac repository is slow with 675 results. with 6K it would be unbareable.

comment:5 Changed 9 years ago by coderanger

  • Cc coderanger@… added

Though its only for queries, the Paginate Tickets plugin does this.

comment:6 Changed 9 years ago by sid

#3135 has been marked as duplicate of this ticket.

comment:7 Changed 9 years ago by Emmanuel Blot

#4708 has been marked as a duplicate

comment:8 Changed 9 years ago by Christian Boos

We should do the same for custom queries.

(#4712 closed as duplicate)

comment:9 Changed 9 years ago by Christian Boos

#5134 was closed as duplicate, and has a patch for report pagination on top of 0.10.x.

Changed 9 years ago by liris <liris.pp@…>

paginate patch for report

comment:10 Changed 9 years ago by liris <liris.pp@…>

I attached the paginate patch for report. It works on trunc repository.

comment:11 Changed 8 years ago by Christian Boos

  • Keywords paginate query added
  • Milestone changed from 1.0 to 0.12
  • Owner changed from Jonas Borgström to Christian Boos
  • Priority changed from normal to high

#6127 has a solid starting point for this feature, see attachment:ticket:6127:Trac-0.11b1_reportpaginate_r412.patch.

comment:12 Changed 8 years ago by trac-ja@…

  • Cc trac-ja@… added

comment:13 Changed 8 years ago by Christian Boos

  • Milestone changed from 0.12 to 0.11

It seems that rendering the reports has become very costly with 0.11, so this patch comes at the right time.

comment:14 Changed 8 years ago by Christophe Simonis

Django as a new Paginator class that can be used: http://code.djangoproject.com/browser/django/trunk/django/core/paginator.py?rev=7353 (a newer version may exist)

comment:15 Changed 8 years ago by Christian Boos

  • Severity changed from normal to major

We've created a branch for that, starting with the #6127 patch: see r6790 and up.

comment:16 Changed 8 years ago by Christian Boos

  • Resolution set to fixed
  • Status changed from new to closed

Branch merged in trunk in r6901.

Many thanks to the Trac Japanese Translation Team for the initial patch.

Please file eventual problems with this feature as new tickets.

Modify Ticket

Change Properties
Set your email in Preferences
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christian Boos to the specified user.

Add Comment

E-mail address and name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.