Edgewall Software
Modify

Opened 9 years ago

Closed 7 years ago

Last modified 2 months ago

#2119 closed enhancement (fixed)

Previous/next ticket links outside of the context of a query

Reported by: cboos Owned by: cboos
Priority: normal Milestone: 0.11
Component: ticket system Version: 0.9.3
Severity: minor Keywords: navigation links
Cc:
Release Notes:
API Changes:

Description

At some point during the 0.9 development, the links for previous and next tickets disappeared if no query is present in the session.

We miss the possibility to go through the few last created tickets in a sequential way.

I'm not sure if this is by design or a bug.

If this is by design, please consider changing the behavior:

  • next/prev links should point to the next/prev tickets in the query ticket list if the ticket page has been reached either directly from the query page or indirectly, by following another next/prev link while going through the query ticket list
  • otherwise, next/prev links should point to the next/prev ticket in the numerical order

This could be implemented quite simply by adding an in_query argument in the link to the tickets from the query page and in the next/prev links in a ticket page reached by a link having the in_query argument set.

Attachments (0)

Change History (10)

comment:1 Changed 9 years ago by cmlenz

  • Milestone 0.9 deleted
  • Priority changed from normal to low
  • Summary changed from Restore the previous ticket/next ticket links to Previous/next ticket links outside of the context of a query
  • Type changed from defect to enhancement

Just go into the address bar and change the ticket ID there ;-)

Seriously, I don't really see enough value in global prev/next links for tickets, especially not enough to add query-string cruft to ticket URLs.

comment:2 Changed 9 years ago by Rachid.Atori@…

I doi agree with the ticket's author. It seems important to me to navigate from a ticket to the "next" one (meaning of "next" depending on the context). I was already like this in 0.8 versions !

comment:3 Changed 9 years ago by ghost@…

  • Version changed from devel to 0.9.3

I'd agree too. If I click on preset "Active tickets" list, modify the first one and want to look at the next, I have to go back to "Active tickets" list and the manually find the next one. Having "next ticket" link would be very handy.

For the record, KDE's bugzilla has this feature and in practice it's very handy when sorting out some 40+ bug reports.

comment:4 Changed 9 years ago by cmlenz

These last comments are about something different than the original report.

You already get contextual navigation through ticket lists when using ticket queries. You don't with reports (because the reports module isn't getting any real attention anymore, and we're going to be phasing it out).

The original report was about getting previous/next ticket links without any context… i.e. just the next/previous ticket by ID.

comment:5 Changed 8 years ago by anonymous

if i go to "view tickets" there are a few links offered, i press one, and then i get a ticket list. clicking on one of the tickets does NOT give next/previous links. which is not practical at all…

comment:6 Changed 8 years ago by cboos

  • Keywords navigation links added
  • Milestone set to 0.11
  • Owner changed from jonas to cboos
  • Priority changed from low to normal
  • Severity changed from normal to minor

The sequence of tickets outside of a query is relevant in the following use cases:

  1. you want to go through the sequence of the most recent tickets created; usually you start from the Timeline to pick the most recent ticket, then it's more convenient to go from that ticket to the next most recent, rather than going back to the Timeline and chasing the next most recent one.
  2. you happen to remember a ticket number, but not the exact number (it was near 250). Going through a few Next Ticket clicks is faster than having to type #251, #252, etc. in the quickjump form.

I'd like to have this back in the next release, as:

← Previous Ticket | Next Ticket →

In contrast with the above, the prev/next links in the context of a query should be

← Previous Matching Ticket | Back to Query | Next Matching Ticket → .

comment:7 Changed 8 years ago by doballve

+1 to cboos. Both navigation strategies are useful. In either case, Currently you need 3 clicks (view tickets, choose report, choose ticket) just to get to next/prev, that is not very efficient.

comment:8 Changed 7 years ago by cboos

  • Resolution set to fixed
  • Status changed from new to closed

Both my original request and ghost's suggestion in comment:3 were implemented in r4775.

comment:9 Changed 7 years ago by cboos

(#4897 and #5104 were closed as duplicates)

comment:10 Changed 7 years ago by cboos

#5913 was closed as duplicate.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed The owner will remain cboos.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from cboos to the specified user.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.