Edgewall Software
Modify

Opened 9 years ago

Last modified 3 weeks ago

#2035 new enhancement

Changeset commenting

Reported by: polarfox@… Owned by: cboos
Priority: high Milestone: next-major-releases
Component: version control/changeset view Version:
Severity: major Keywords: tracobject journaling comment
Cc: johannes_rudolph@…, a.a.vykhodtsev@…, dale.miller@…, tractickets@…, nicolas@…, interstellar.condition@…, viola@…, rjollos, itamarost@…, mmitar@…, net147@…, tony@…, leho@…
Release Notes:
API Changes:

Description

Commenting on changesets would be great, it would substitute for code review tools.

Attachments (0)

Change History (43)

comment:1 Changed 9 years ago by anonymous

This would actually pave the way for analysis of percentage of reviewed code. An algorithm could try to correlate all latest lines of code in a file to reviews, and calculate how many were reviewed. I wish SCM systems could help here, because they already have some of that algorithm's bits when they re-create a given revision of a file based on changes preceding it.

comment:2 Changed 9 years ago by cboos

  • Owner changed from jonas to cboos
  • Severity changed from normal to major
  • Status changed from new to assigned

Yes, I made a similar proposal, for generalizing comments to all Trac objects (see TracObjectModelProposal, it's a bit dusty now, but I'll update it in the following weeks).

For the specific purpose of code review, I see the need for some more additions:

  • simpler linking to the filenames concerned by the changeset (see #124)
  • wiki syntax for linking to line numbers.
    As we will support the peg revision format (see #2011), why not use the # delimiter to refer to the line number? … or the : delimiter, for not introducing an incompatible change? (I'll open a new ticket for that feature, but we already have half of the features, i.e. the anchors to the lines, see #1798)
  • complement the blame feature with review annotations (see #629)

comment:3 Changed 9 years ago by antranig@…

I think the Object Model proposal sounds great. I am currently deciding between Confluence and Trac for a project I am working on, and a big win of Confluence is that it allows comments to be attached to arbitrary pages. Of course a big loss is its terrible UI model, so I am still undecided. I would like very much to be able to enable/disable blog-style comments on each page in Trac.

comment:4 Changed 9 years ago by eblot

Have a look at the AddComment macro: it's a useful tool to add comments to a wiki page. However, this does not relate much to the original subject of this ticket.

comment:5 Changed 9 years ago by cboos

  • Status changed from assigned to new

(changing the status, as I've not actually started to work on that yet)

comment:6 Changed 9 years ago by cboos

  • Keywords object added

comment:7 Changed 9 years ago by mgood

#2520 has been marked as a duplicate of this ticket.

comment:8 Changed 9 years ago by cboos

  • Keywords tracobject added; object removed

comment:9 Changed 8 years ago by cboos

  • Keywords journaling added

See also TracDev/Proposals/Journaling.

In that perspective, comments would be stored in a separate comment table,

tidtypeidtextreplyto

And the replyto would refer to the tid of the "replied to" comment, if there's one.

comment:10 Changed 8 years ago by cboos

  • Keywords comment added
  • Milestone set to 1.0

There's also the related idea expressed in #4279, which is being able to annotate any given page. That would be even more adapted for code reviews.

The Discussion tab would be more appropriate for general comments about the resource.

Now I wonder if the two ideas couldn't be combined: in case a general comment is referring to some particular location in the resource, there could be an indicator at that location which could link back to the specific comment.

comment:11 Changed 8 years ago by cboos

#4313 was marked as duplicate, and actually illustrates quite nicely what I said above.

comment:12 Changed 8 years ago by bill.mill@…

Well, as the author of the above dupe (sorry), I'll just change my ticket to a vote for this feature. It would be killer!

(I just wanted it again today, which reminded me to head back here to check the status of my ticket :)

comment:13 Changed 8 years ago by cboos

#5133 was closed as duplicate, and was also requesting the ability to annotate changesets for code review purpose.

comment:14 follow-up: Changed 7 years ago by az@…

just to add another little bit of emphasis: this is one of the things i miss most with trac, since we're using the timeline to review each others changes constantly, and having to create tickets for commenting other changes is some cumbersome… :)

comment:15 follow-up: Changed 7 years ago by cboos

  • Milestone changed from 1.0 to 0.12
  • Priority changed from normal to high

You convinced me ;-)

comment:16 in reply to: ↑ 14 Changed 7 years ago by az@…

Replying to az@zitc.de:

commenting other changes is some cumbersome… :)

that should have read "commenting other changesets is somewhat cumbersome", of course… :)

comment:17 in reply to: ↑ 15 Changed 7 years ago by az@…

Replying to cboos:

You convinced me ;-)

excellent, i'm very much looking forward to it! :)

comment:18 Changed 7 years ago by Johannes Rudolph <johannes_rudolph@…>

  • Cc johannes_rudolph@… added

comment:19 Changed 6 years ago by a.a.vykhodtsev@…

  • Cc a.a.vykhodtsev@… added

comment:20 follow-up: Changed 6 years ago by anonymous

Testing writing a comment!

comment:21 in reply to: ↑ 20 Changed 6 years ago by eblot

Replying to anonymous:

Testing writing a comment!

Stop that. Which part of "this is not a test system" did you not understand?

comment:22 Changed 6 years ago by dale.miller@…

  • Cc dale.miller@… added

comment:23 Changed 6 years ago by tractickets@…

  • Cc tractickets@… added

comment:24 Changed 6 years ago by elecnix <nicolas@…>

  • Cc nicolas@… added

comment:25 Changed 6 years ago by osimons

#8092 closed as duplicate.

comment:26 Changed 5 years ago by cboos

comment:27 Changed 5 years ago by interstellar.condition@…

#8771 closed as duplicate.

comment:28 Changed 5 years ago by interstellar.condition@…

  • Cc interstellar.condition@… added

comment:29 Changed 5 years ago by viola@…

  • Cc viola@… added

May I draw your attention to yet another hack addressing this issue? We are impressed by the simplicity by which this could be achieved via a plugin. The hack is not final and not feature-rich yet, but (release early;-) shows the idea.

comment:30 Changed 5 years ago by viola@…

Sorry, I should add the address: http://trac-hacks.org/wiki/CodeReviewPlugin

comment:31 Changed 5 years ago by cboos

http://blog.gitorious.org/2009/11/06/awesome-code-review

Which makes me think that it would be nice if the changeset commenting logic could also apply to patches.

comment:32 Changed 5 years ago by Ryan Ollos <ryano@…>

  • Cc ryano@… added

comment:33 Changed 5 years ago by cboos

Another source of inspiration: http://www.reviewboard.org/screenshots/

comment:34 Changed 5 years ago by Ryan Ollos <ryano@…>

There are two other code review tools discussed on tho that seem to be of interest to users, trachacks:#2661 and trachacks:#5889.

I also recently came across GvnTrac. I wasn't previously aware of this project because there is not a stub page on tho for it. At present, there appear to be 3 codereview plugins that integrate with Trac: th:CodeReviewPlug, th:PeerReviewPlugin, and GvnTrac.

comment:35 Changed 5 years ago by Ryan Ollos <ryano@…>

Came across another code review tool for Trac and added a stub page to t-h.o: th:ExoWebCodeReviewPlugin. It was discussed in this StackOverflow thread.

comment:37 Changed 4 years ago by itamaro

  • Cc itamarost@… added

comment:38 Changed 3 years ago by Mitar

  • Cc mmitar@… added

comment:39 Changed 18 months ago by net147@…

  • Cc net147@… added

comment:40 Changed 10 months ago by tony@…

  • Cc tony@… added

comment:41 Changed 10 months ago by rjollos

  • Cc rjollos added; ryano@… removed

comment:42 Changed 4 months ago by psuter

#11676 proposes a reusable comment module that could be used to implement changeset comments.

comment:43 Changed 2 months ago by lkraav <leho@…>

  • Cc leho@… added

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as new The owner will remain cboos.
as The resolution will be set. Next status will be 'closed'.
The owner will be changed from cboos to anonymous. Next status will be 'assigned'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.