Edgewall Software
Modify

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#1736 closed defect (duplicate)

problem when accepting tickets with Opera 8.01 and trac 0.83 (Opera 8.51 + trac .9)

Reported by: todor_totev@… Owned by: jonas
Priority: normal Milestone:
Component: general Version: devel
Severity: critical Keywords:
Cc:
Release Notes:
API Changes:

Description

When I change the action in a currently viewed ticket (for example I accept it) and press the Submit button, Opera simply halts. I can see the progress bar which indicates it is downloading info but it is frozen forever. When I manually stop and refresh the page, I receive the updated page reflecting the fact I accepted the ticket. This behaviour is with Opera 7.54 & 8.0 & 8.01 under Windows XPSP2. Tested Trac versions are 0.82 & 0.83. The server is Apache 2.0.54 under Windows Server 2003.

Attachments (0)

Change History (9)

comment:1 Changed 9 years ago by anonymous

Just to add, I'm using CGI version of Trac (not using mod_python or tracd) and Python is 2.3.5

comment:2 Changed 9 years ago by gary@…

  • Component changed from ticket system to general
  • Milestone set to 1.0
  • Severity changed from normal to critical
  • Version changed from 0.8.3 to devel

An addendum from another user here. The error occurs with posting large dataset (7k) in form, and occurs for both Opera and IE. This is for submission of any large form data to trac. The post would run and timeout. Posting the same works in Firefox / moz however.

comment:3 Changed 9 years ago by anonymous

  • Summary changed from problem when accepting tickets with Opera 8.01 and trac 0.83 to problem when accepting tickets with Opera8.01 and trac 0.83 (Opera 8.51 + trac .9)

Another note: Under Linux using Opera 8.51 the exact same problem appears but it does *not* seem to relate to large posts. Any change to a ticket will halt (or rather, spin in a post until timeout) upon submit. Subsequent submits will give the "mid-air collision" error, but a refresh shows the changes intact. I'm using the CGI version of trac .9 as well.

comment:4 Changed 9 years ago by somazx [ AT ] gmail.com

in my tests this didn't occur in IE - only Opera. if after processing the form trac does a redirect (which it seems to do and likely should/would) to redisplay the ticket, then I would suspect opera isn't liking the redirect/headers.

comment:5 Changed 9 years ago by terry.dooher AT naturalmotion.com

I have also spotted this issue with CGI trac 0.9.3 (Python 2.3) in Opera 8.0 and IE 6. Since switching to mod_python, however, I haven't seen it since.

As an aside, the switch to mod_python not only vastly improved the speed of the system, but it cured a possibly related issue whereby the style sheet and images for any given page (tickets and wiki pages tested) didn't load on every other refresh. I could repeatedly hit F5 and every second go would finish loading as unstyled HTML. This also affected IE 6 and Opera 8.0.

comment:6 Changed 9 years ago by pistos

FWIW, I get both problems (1. can't update ticket; 2. sometimes pages don't load properly). My specs:

Trac 0.9.3 Opera 8.52 Apache 2.0.55 mod_fastcgi 2.4.2 FastCGI 2.4.0

comment:7 Changed 9 years ago by pistos

Forgot to say: Both the browser and the server are running on the same machine, Gentoo with kernel 2.6.15(-gentoo).

comment:8 Changed 9 years ago by anonymous

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1969.

comment:9 Changed 8 years ago by anonymous

  • Milestone 1.0 deleted

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed The owner will remain jonas.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from jonas to the specified user.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.