Edgewall Software

Opened 10 years ago

Closed 10 years ago

#1718 closed defect (fixed)

Error with browsing tickets

Reported by: wuntvor Owned by: Matthew Good
Priority: normal Milestone:
Component: ticket system Version: devel
Severity: normal Keywords:
Release Notes:
API Changes:


After updating to the latest revision (1861) I can't access the ticket system anymore. When I click on "View Tickets", all I get is an internal error "global name 'perm' is not defined". I did search the site and on the net without being able to find anything, so I hope that this is indeed something new. If not, then I apologize.

Traceback is as follows:

Traceback (most recent call last):

File "/usr/lib/python2.3/site-packages/trac/web/modpython_frontend.py", line 265, in handler

dispatch_request(mpr.path_info, mpr, env)

File "/usr/lib/python2.3/site-packages/trac/web/main.py", line 423, in dispatch_request


File "/usr/lib/python2.3/site-packages/trac/web/main.py", line 285, in dispatch

resp = chosen_handler.process_request(req)

File "/usr/lib/python2.3/site-packages/trac/ticket/report.py", line 127, in process_request

resp = self._render_view(req, db, id)

File "/usr/lib/python2.3/site-packages/trac/ticket/report.py", line 247, in _render_view

actions = {'create': perm.REPORT_CREATE, 'delete': perm.REPORT_DELETE,

NameError?: global name 'perm' is not defined

Attachments (0)

Change History (4)

comment:1 Changed 10 years ago by anonymous

  • Resolution set to invalid
  • Status changed from new to closed

Sorry, it was actually caused by my configuration, it seems.. I messed something up when I tried to set up a second trac. :(

comment:2 Changed 10 years ago by Matthew Good

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:3 Changed 10 years ago by Matthew Good

  • Owner changed from Jonas Borgström to Matthew Good
  • Status changed from reopened to new

Actually I saw this error too. I'll check in a fix in a minute.

comment:4 Changed 10 years ago by Matthew Good

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in [1862]

Modify Ticket

Change Properties
Set your email in Preferences
as closed The owner will remain Matthew Good.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Matthew Good to the specified user.

Add Comment

E-mail address and name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.