Edgewall Software
Modify

Opened 8 months ago

Closed 8 months ago

Last modified 8 months ago

#11388 closed defect (cantfix)

AttributeError: 'Environment' object has no attribute 'disable_component'

Reported by: giannis Owned by:
Priority: normal Milestone:
Component: general Version:
Severity: normal Keywords:
Cc:
Release Notes:
API Changes:

Description

How to Reproduce

While doing a GET operation on /admin, Trac issued an internal error.

(please provide additional details here)

User Agent was: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0

System Information

Trac 0.11.2.1
Python 2.4.3 (#1, May 24 2008, 13:57:05)
[GCC 4.1.2 20070626 (Red Hat 4.1.2-14)]
setuptools 0.6c7
SQLite 3.3.6
pysqlite 1.1.7
Genshi 0.5.1
mod_python 3.2.8
Pygments 1.0
jQuery: 1.2.6

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/Trac-0.11.2.1-py2.4.egg/trac/web/main.py", line 432, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/Trac-0.11.2.1-py2.4.egg/trac/web/main.py", line 164, in dispatch
    for handler in self.handlers:
  File "/usr/lib/python2.4/site-packages/Trac-0.11.2.1-py2.4.egg/trac/core.py", line 67, in extensions
    return filter(None, [component.compmgr[cls] for cls in extensions])
  File "/usr/lib/python2.4/site-packages/Trac-0.11.2.1-py2.4.egg/trac/core.py", line 204, in __getitem__
    component = cls(self)
  File "/usr/lib/python2.4/site-packages/Trac-0.11.2.1-py2.4.egg/trac/core.py", line 108, in maybe_init
    init(self)
  File "build/bdist.linux-x86_64/egg/estimationtools/utils.py", line 57, in __init__
AttributeError: 'Environment' object has no attribute 'disable_component'

Attachments (0)

Change History (2)

comment:1 Changed 8 months ago by jomae

  • Resolution set to cantfix
  • Status changed from new to closed

PluginIssue (th:EstimationToolsPlugin). Also disable_component method is available since Trac 0.11.3.

comment:2 Changed 8 months ago by rjollos

Thanks, Jun. I added a minimum version requirement to th:EstimationToolsPlugin in [th 13472].

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.