Edgewall Software
Modify

#10881 closed defect (worksforme)

referencing tickets in descending order in commit messages creates duplicate comment numbers

Reported by: Richard Rogers <rprogers@…> Owned by:
Priority: normal Milestone:
Component: ticket system Version: 0.12.2
Severity: critical Keywords:
Cc:
Release Notes:
API Changes:

Description

How to reproduce:

1) have 2 tickets with numbers X and Y, where X < Y, Y having more comments than X 2) do a commit with message "refs #Y and #X"

Ticket X gets a new correctly numbered comment, but Y gets a comment with the same number that was added to X creating a duplicate comment number in ticket Y. "refs #X and #Y" seems to work correctly for both tickets.

This doesn't seem to occur with 0.12.4 or 1.0, but it's unclear if the underlying issue has actually been fixed.

System information:

lungs [1006] cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 5.8 (Tikanga)
Trac 0.12.2
Bitten0.6
Genshi0.6 (without speedups)
Mercurial1.8.2
MySQLserver: "5.0.95", client: "5.0.95", thread-safe: 1
MySQLdb1.2.3
Python2.6.4 (r264:75706, Feb 23 2010, 12:33:58) [GCC 4.3.1]
pytz2010h
setuptools0.6c11
jQuery:1.4.2

Attachments (0)

Change History (1)

comment:1 Changed 22 months ago by rblank

  • Resolution set to worksforme
  • Status changed from new to closed

We had some issues with comment numbering in early 0.12.x releases, which seem to have been fixed since (although I'm not sure which changeset actually fixed it, but we never saw the symptom again). I would advise upgrading to 0.12.4.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.