Edgewall Software
Modify

Opened 10 years ago

Closed 9 years ago

Last modified 8 years ago

#1030 closed defect (worksforme)

smtp_always_cc do not work

Reported by: achim@… Owned by: jonas
Priority: high Milestone:
Component: ticket system Version: 0.8.1
Severity: critical Keywords: notification
Cc: peter@…, m.kooijman@…
Release Notes:
API Changes:

Description

smtp_always_cc do not work with inividual mails or mailing lists. it is only possible to send mails if i use the Cc: input for a new ticket. the mails from smtp_always_cc gets always ignored.

achim

Attachments (1)

trac.ini (984 bytes) - added by peter@… 9 years ago.
trac.ini with non-working smtp_always_cc

Download all attachments as: .zip

Change History (10)

comment:1 Changed 10 years ago by achim@…

  • Resolution set to fixed
  • Status changed from new to closed

It works for me now. May be it was a temporary problem…

comment:2 Changed 9 years ago by peter@…

  • Milestone changed from 0.8.1 to 0.8.2
  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Version changed from 0.8 to 0.8.1

Just set everything up, and I'm seeing this here as well.

To confirm:

The email address in smtp_always_cc (known good) never receives any email.

If you then place that address in the CC: field, email is sent properly.

Trac 0.8.1, Fedora Core 3, Python 2.3.4.

This is a big issue - without email notification, a bug tracking system looses a lot of value.

comment:3 Changed 9 years ago by aashley@…

When first setting up our trac installations I encountered this problem but it was always traceable back to a cached trac.ini file. Restarting the web server would always fix it.

comment:4 Changed 9 years ago by peter@…

  • Cc peter@… added

Bouncing the webserver didn't do it. smtp_always_cc is still not working.

Note: Even though I entered my email address when posting the bug, I never received anything about my initial post, or any of the responses to it. Shouldn't that be enabled here?

Hardcoding my address in the CC field so I get further responses.

comment:5 Changed 9 years ago by mgood

Can you attach your trac.ini file here? I have several projects running on 0.8.1 with smtp_always_cc on, so I do know that it generally works.

Changed 9 years ago by peter@…

trac.ini with non-working smtp_always_cc

comment:6 Changed 9 years ago by peter@…

Added the trac.ini. For the record, I just re-started apache again, and it still isn't sending mail.

Additionally, explicitely adding the email address in smtp_always_cc to the Cc: field does work - so it's not a general mail issue.

comment:7 Changed 9 years ago by cmlenz

  • Milestone 0.8.2 deleted

As this feature does seem to work for many other users, and I don't know where the problem might be, this ticket should not block the release of 0.8.2.

comment:8 Changed 9 years ago by Matthijs Kooijman <m.kooijman@…>

  • Cc m.kooijman@… added

I've been struggeling with email notification for a while too, but it works now (even with correct formatting ;-)

Anyway, could you try to enable logging by putting

log_type = file

in your trac.ini? It should then log stuff to the file trac.log in your trac environment directory. I presume an exception will be reported there, if for whatever reason the mail could not be sent.

comment:9 Changed 9 years ago by cmlenz

  • Keywords notification added
  • Resolution set to worksforme
  • Status changed from reopened to closed

Unable to reproduce. At the very least, we need the DEBUG log output.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed The owner will remain jonas.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from jonas to the specified user.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.